Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84984 - firstboot error: gethostbyaddr() argument 1 must be string, not None
Summary: firstboot error: gethostbyaddr() argument 1 must be string, not None
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-24 18:23 UTC by Nathan Wallwork
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:57 UTC


Attachments (Terms of Use)

Description Nathan Wallwork 2003-02-24 18:23:43 UTC
Description of problem:

firstboot produced an error while attempting to set date/time.
Error appears to be related to DNS failure.


Version-Release number of selected component (if applicable):


How reproducible:

Installed phoebe (custom, everything) on a typical host, configured eth0
without DHCP, provided an IP address, gateway, bogus hostname (test4.linux.test)
and a valid DNS server that doesn't know this hostname, domain, or even the IP 
address of the machine.  Network connectivity to that DNS server is functional.


Steps to Reproduce:
1.
2.
3.
    
Actual results:

After rebooting, the firstboot generated a message while attempting to set the
date, but generated the error message (above) instead.

Expected results:


Additional info:

Comment 1 Nathan Wallwork 2003-02-24 18:32:33 UTC
[root@test4 root]# more firstboot.1046134484.72
Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None
[root@test4 root]#

[root@test4 root]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:04:75:39:82:0A
          inet addr:192.168.30.204  Bcast:192.168.30.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5926 errors:0 dropped:0 overruns:10 frame:0
          TX packets:3331 errors:0 dropped:0 overruns:0 carrier:0
          collisions:4 txqueuelen:100
          RX bytes:1878743 (1.7 Mb)  TX bytes:451085 (440.5 Kb)
          Interrupt:5 Base address:0x2000
 
[root@test4 root]# dig -x 192.168.30.204
 
; <<>> DiG 9.2.1 <<>> -x 192.168.30.204
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17892
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
 
;; QUESTION SECTION:
;204.30.168.192.in-addr.arpa.   IN      PTR
 
;; AUTHORITY SECTION:
168.192.in-addr.arpa.   85830   IN      SOA     prisoner.iana.org.
hostmaster.root-servers.org. 2002040800 1800 900 604800 330
 
;; Query time: 265 msec
;; SERVER: 10.1.33.99#53(10.1.33.99)
;; WHEN: Mon Feb 24 18:29:09 2003
;; MSG SIZE  rcvd: 122
 [root@test4 root]# uname -a
Linux test4.linux.test 2.4.20-2.21 #1 Wed Jan 15 20:31:35 EST 2003 i686 i686
i386 GNU/Linux
[root@test4 root]# dig test4.linux.test
 
; <<>> DiG 9.2.1 <<>> test4.linux.test
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 16122
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
 
;; QUESTION SECTION:
;test4.linux.test.              IN      A
 
;; AUTHORITY SECTION:
.                       2556    IN      SOA     ns. hostmaster. 1046095214 16384
2048 1048576 288
 
;; Query time: 226 msec
;; SERVER: 10.1.33.99#53(10.1.33.99)
;; WHEN: Mon Feb 24 18:29:40 2003
;; MSG SIZE  rcvd: 81
 




Comment 2 Brent Fox 2003-02-24 23:24:28 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.