Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84978 - workspace switcher doesn't correctly load space names on login
Summary: workspace switcher doesn't correctly load space names on login
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libwnck
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
: 87567 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-24 16:45 UTC by Ian Macdonald
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-24 22:14:27 UTC


Attachments (Terms of Use)

Description Ian Macdonald 2003-02-24 16:45:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.2.1) Gecko/20030206

Description of problem:
GNOME panel workspace names are not saved across sessions in the switcher applet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. right click on switcher applet
2. choose preferences
3. modify workspace names
4. log out of GNOME session
5. log back in
    

Actual Results:  The workspace names revert to Workspace 1, Workspace 2, etc.

Expected Results:  The names should have been retained.

Additional info:

Comment 1 Havoc Pennington 2003-03-29 00:08:18 UTC
*** Bug 87567 has been marked as a duplicate of this bug. ***

Comment 2 Ian Macdonald 2003-03-29 00:20:31 UTC
If I run 'gconftool-2 -R /apps/metacity/workspace_names', this shows the names
of the workspaces correctly, so they *are* getting saved. Indeed, right-clicking
on the desktop shows all of the names correctly in the menu.

So, it seems it's just the workspace switcher applet that doesn't load them
correctly at log-in time.



Comment 3 Havoc Pennington 2003-03-29 00:55:09 UTC
They are also correct in the per-window menu? (top left corner in default theme?)

This sounds more like a known bug, then. It happens if the workspace switcher
starts before metacity does, I think, or something like that. Then metacity
hasn't yet provided the space names. There may be a bugzilla.gnome.org bug for it 
already.

Comment 4 Ian Macdonald 2003-03-29 01:01:49 UTC
Yes, the menu is correct.

I tested your theory by removing the workspace switcher from the panel and
re-adding it, which should theoretically have forced it to reread the file and
pick up the names, but it didn't.


Comment 5 Havoc Pennington 2003-03-29 01:08:58 UTC
It might be better to "killall gnome-panel" instead of just removing/readding that 
applet, as the libwnck code doesn't get unloaded on removing it most likely.

Though it could definitely be a different problem.

Comment 6 Ian Macdonald 2003-03-29 01:12:17 UTC
'killall gnome-panel' doesn't fix it either, I'm afraid.

Comment 7 Havoc Pennington 2003-03-29 02:54:11 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=102293

Comment 8 Mark McLoughlin 2004-08-24 22:14:27 UTC
Long since resolved, it seems


Note You need to log in before you can comment on or make changes to this bug.