Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84963 - audiofile miss implementation of afOpenVirtualFile
Summary: audiofile miss implementation of afOpenVirtualFile
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: audiofile
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-24 13:45 UTC by Christian Schaller
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-05-19 19:28:55 UTC


Attachments (Terms of Use)
Debian audiofile patch (been used/tested in debian for a long time) (deleted)
2003-02-24 13:47 UTC, Christian Schaller
no flags Details | Diff

Description Christian Schaller 2003-02-24 13:45:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
The standard audiofile package lacks an implementation of afOpenVirtualFile, the
implementation of this has been merged into the official audiofile CVS tree over
a year ago, but even after repeated requests by us and others has new release
been made. Attached is the patch that Debian has shipped for a long time now
containing this fix.

The GStreamer audiofile plugin needs this addition in order to work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
n/a

Actual Results:  n/a

Expected Results:  n/a

Additional info:

n/a

Comment 1 Christian Schaller 2003-02-24 13:47:06 UTC
Created attachment 90309 [details]
Debian audiofile patch (been used/tested in debian for a long time)

Comment 2 Havoc Pennington 2003-07-30 19:50:46 UTC
Any chance audiofile has made a release in the last few months?

This patch looks like it changes the library ABI, plus it's just 
plain huge...

Comment 3 Christian Schaller 2003-07-30 22:38:26 UTC
Sorry, no audiofile release in the last months :(
The patch has been shipping with Debian for a long time and Frederic has merged
it into Mandrake afaik, so it should be rather safe. 

Without this patch the GStreamer audiofile plugin has no way of working.

Comment 4 Christian Schaller 2003-10-08 17:16:35 UTC
I noticed that there actually was a new audiofile release recently. Which I
guess makes the need for this patch obsolete.

Comment 5 Havoc Pennington 2003-10-08 20:07:25 UTC
Yep, but we do need to upgrade audiofile I think (maybe only in the next release
though).

Comment 6 Colin Walters 2004-05-19 19:28:55 UTC
I verified our latest audiofile has afOpenVirtualFile.


Note You need to log in before you can comment on or make changes to this bug.