Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84951 - missing Dutch [nl] entry in redhat-config-keyboard.desktop
Summary: missing Dutch [nl] entry in redhat-config-keyboard.desktop
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-keyboard
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-24 09:14 UTC by Tino Meinen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-20 17:33:56 UTC


Attachments (Terms of Use)

Description Tino Meinen 2003-02-24 09:14:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Using Phoebe-3
In the Red Hat Menu, there are a number items (including their tooltip) that
don't show the Dutch translation, whereas the specific message is translated
into Dutch in the corresponding po-file.

This seems to stem from the fact that the corresponding .desktop file which is
located in "/usr/share/applications/" is missing the [nl] entry.

one of the items is "Keyboard" found via the System Settings menu.
This corresponds to the file redhat-config-keyboard.desktop.
The translated messages are found in the po file for redhat-config-keyboard
------------
This is only one of several (red hat) specific items.
The other (red hat specific ones) are:
(note, i've listed the corresponding po file in brackets)

redhat-authconfig.desktop
        missing dutch entry (authconfig)

redhat-hwbrowser.desktop
        missing dutch entry (hwbrowser)

redhat-config-keyboard.desktop 
        missing dutch entry (redhat-config-keyboard)

redhat-config-kickstart.desktop
        missing dutch entry (redhat-config-kickstart)

redhat-config-language.desktop
        contains old dutch translations (redhat-config-language)

redhat-config-nfs.desktop
        missing dutch entry (redhat-config-nfs)

redhat-config-packages.desktop
        old dutch translations (redhat-config-packages)

redhat-config-proc.desktop
        missing dutch entry (redhat-config-proc)

redhat-config-services.desktop
        (Only Name entries are translated, Comment is apparently not       
translatable (the Comment/tooltip is: "Configure which services will be running
when the system starts")

redhat-config-soundcard.desktop
        missing dutch entry (redhat-config-soundcard)

redhat-switch-printer.desktop
        missing every language entry

redhat-userinfo.desktop
        missing dutch entry (usermode)


the switchdesk po file doesn't seem to have a associated .desktop file:
missing .desktop file for switchdesk

------
Hope this information helps, and hopefully my explanation was clear enough.
(this is my first red hat bugreport)

Thanks
Tino Meinen
a.t.meinen@chello.nl







Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. log in using the Dutch language for the session
2. view the menu

    

Actual Results:  Several items, including the one for Keyboard are not shown in
Dutch 
    

Expected Results:  Tanslated menu items! :-)

Additional info:

I have no idea if this has to be manually inserted into the .desktop files or if
somhting like putting nl into a configure.in file will fix this. 
It should however not be too difficult methinks

Please inform me if I have to file bugs for every single component
(would mean a lot of work for me though) instead of just using this one.

Comment 1 Miloslav Trmac 2003-02-28 14:15:09 UTC
Please fix this in redhat-config-keyboard for cs (Czech) too.

Comment 2 Brent Fox 2003-03-19 22:22:40 UTC
I know this is a pain, but can you please file separate reports for these issues?  

It really helps since many of these packages do not have the same owner in Bugzilla.

Comment 3 Brent Fox 2003-03-20 17:33:56 UTC
Ok, I have updated the keyboard, language, mouse, soundcard, nfs, hwbrowser,
kickstart, and user tools for Dutch.  Please file separate bug reports for the
other tools since I don't own those packages.

Miloslav, I added the Czech translations to the redhat-config-keyboard.desktop
file as well.

I'm closing this report as Rawhide, but I can't rebuild packages at the moment
but  they will appear in Rawhide sometime soon.

Comment 4 Tino Meinen 2003-03-20 19:29:09 UTC
Ok, Thank you very much Brent!
I was dreading to file so many bugreports, but this will cut the work in half.
I will file bugreports on the remaining modules

I'm curious to why this is such handicraft-like work.
I thought all these things were automated.
(e.g. a .desktop file is automatically generated/updated once the corresponding
po file is added/updated.)
But it appears not to work that way.
This means there will be a lot of work, keeping up with all the additional
languages that are being added recently to the Red Hat tree.

Closing the bug as rawhide means what?




Comment 5 Brent Fox 2003-03-20 19:56:48 UTC
Rawhide means that updated packages will be avialable in the Rawhide directory
on our FTP sites and mirrors.

ftp://distro.ibiblio.org/pub/linux/distributions/redhat/rawhide/i386/RedHat/RPMS

However, I'm not able to make updated packages at the moment.  I will rebuild
them soon, though.


Note You need to log in before you can comment on or make changes to this bug.