Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84939 - Problems with trident sound driver on Acer Travelmate Laptop
Summary: Problems with trident sound driver on Acer Travelmate Laptop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-24 06:33 UTC by Peter Robinson
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-05 17:11:40 UTC


Attachments (Terms of Use)

Description Peter Robinson 2003-02-24 06:33:56 UTC
Description of problem:
I have an Acer TravelMate 524TXV laptop with a trident based (ALI 5451) Sound
Card. On 'modprobe trident' or via the GNOME Based Sound card config tool the
sound card doesn't work. 

Version-Release number of selected component (if applicable):
Redhat Linux Phoebe Beta - 15th Feb 2003

How reproducible:
modprobe trident on laptop, look at dmesg output.

Actual results:
The X Windows interface complains unable to open sound device

Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio, version 0.14.10h,
11:58:39 Feb 13 2003
PCI: Guessed IRQ 10 for device 00:06.0
trident: ALi Audio Accelerator found at IO 0x9000, IRQ 10
ALi 5451 did not come out of reset.


Expected results:
For sound to work.

Additional info:
Beta released with ISOs Dated 15th Feb 2003

PIII Laptop with 256Mb RAM, clean RedHat install dual booting with Windows 2000

Comment 1 Peter Robinson 2003-03-05 15:35:39 UTC
It looks like this bug has been fixed in the driver update as per kernel 2.5.64

Quoted from the kernel changelog. Which appears to be the problem I have been
having.

I think this is happening in earlier versions of Redhat as well (specifically
8.0 and possibly 7.3)

<mulix@mulix.org>
[PATCH] trident 1/3 fix "did not come out of reset"
The M5451 can sometimes not come out of reset. This is non fatal and it
continues to work fine, so print a nasty message but don't fail the driver
initialization.

<mulix@mulix.org>
[PATCH] trident 2/3 make me the maintainer
Make Muli Ben-Yehuda the maintainer for trident as per Alan's suggestion

<mulix@mulix.org>
[PATCH] trident 3/3 use pr_debug instead of TRDBG
use the standard pr_debug macro instead of TRDBG


Comment 2 Stefan Ekman 2003-03-15 07:40:49 UTC
I have the same problem on Acer Travelmate 525txv, but did not have it in RH8.0.
The computer totally freezes during modprobe.

Comment 3 Stefan Ekman 2003-03-16 07:49:54 UTC
It works with ALSA-drivers from
http://ftp.freshrpms.net/pub/freshrpms/redhat/testing/phoebe/.

Comment 4 Stefan Ekman 2003-03-16 08:05:16 UTC
85930 is the same thing.

Comment 5 Alan Cox 2003-06-05 17:11:40 UTC
Fixed in errata kernel



Note You need to log in before you can comment on or make changes to this bug.