Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84937 - can't remove some packages
Summary: can't remove some packages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-24 03:44 UTC by Jens Knutson
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 20:23:01 UTC


Attachments (Terms of Use)
The error message I get when trying to remove kdegames (deleted)
2003-02-24 03:44 UTC, Jens Knutson
no flags Details
snapshot for comment #2 (deleted)
2003-02-26 15:27 UTC, Michael Schwendt
no flags Details

Description Jens Knutson 2003-02-24 03:44:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Using redhat-config-packages, I am unable to remove some packages due to
unresolved dependencies, such as kdegames and mikmod.

Attached is a screenshot of the error message I get when trying to remove kdegames.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. After doing a "Personal Desktop" install of RHL, open redhat-config-packages
2. Attempt to remove kdegames with r-c-p


Additional info:

Comment 1 Jens Knutson 2003-02-24 03:44:59 UTC
Created attachment 90303 [details]
The error message I get when trying to remove kdegames

Comment 2 Michael Schwendt 2003-02-26 15:26:19 UTC
Just wanted to submit a similar bug when I found that this one describes the
same symptoms.

I started with a customized workstation installation and wanted to remove _all_
development packages. The result is this (also note attached screenshot):

$ redhat-config-packages
* Core references package efibootmgr which doesn't exist
* Core references package elilo which doesn't exist
Unselecting libxslt-devel already marked for removal
Unselecting already uninstalled package glade
Unselecting already uninstalled package splint
Unselecting already uninstalled package ElectricFence
Unselecting already uninstalled package expect
Unselecting already uninstalled package cproto
Unselecting already uninstalled package nasm
Unselecting already uninstalled package automake14
Unselecting already uninstalled package gcc-g77
Unselecting already uninstalled package gcc-objc
Unselecting already uninstalled package ddd
Unselecting already uninstalled package gcc-gnat
Unselecting already uninstalled package pstack
Unselecting already uninstalled package dmalloc
Unselecting already uninstalled package njamd
Unselecting already uninstalled package gcc-java
Unselecting already uninstalled package dejagnu
Unselecting already uninstalled package pmake
* depcheck: package audiofile-devel needs pkgconfig >= 0.8 (not provided)
* depcheck: package compat-gcc needs binutils >= 2.12.90.0.7-1 (not provided)
* depcheck: package mod_ssl needs make (not provided)
* depcheck: package stunnel needs make (not provided)
* depcheck: package gstreamer-devel needs glib2-devel >= 2.0.1 (not provided)
('pkgconfig', '0.8', 12)
('binutils', '2.12.90.0.7-1', 12)
('make', None, 0)
('make', None, 0)
('glib2-devel', '2.0.1', 12)

The critical error message and list of unlocatable packages  is confusing, since
the packages it complains about are installed.

$ rpm -q pkgconfig binutils make glib2-devel
pkgconfig-0.14.0-3
binutils-2.13.90.0.18-6
make-3.79.1-17
glib2-devel-2.2.1-1

Apparently, it tries to uninstall those packages from the development group
which are strictly required by other packages not in the development group.

Comment 3 Michael Schwendt 2003-02-26 15:27:21 UTC
Created attachment 90378 [details]
snapshot for comment #2

Comment 4 Mike McLean 2003-02-26 20:10:29 UTC
observed in redhat-config-packages-1.1.8-1

after an everything install, opened the tool, deselected SQL Database Server and
News Server, and clicked Forward. Got a "Packages Not Found" error similar to
the one above.

Comment 5 Jeremy Katz 2005-09-21 20:23:01 UTC
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.


Note You need to log in before you can comment on or make changes to this bug.