Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84897 - gftp 2.0 can't enter directory with Chinese names
Summary: gftp 2.0 can't enter directory with Chinese names
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gftp
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-23 06:49 UTC by Need Real Name
Modified: 2013-04-02 04:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-10 05:43:06 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-02-23 06:49:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.2.1) Gecko/20030206

Description of problem:
When I use gftp 2.0 (the xft version) to log into a ftp server, I find that gftp
can only enter directory with English names (e.g. pub, incoming, etc.). For
directory with Chinese names (e.g. ��ת�ļ�ר��Ŀ¼), gftp complains that "550
/incoming/��ת�ļ�ר��Ŀ¼: No such file or directory."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use gftp 2.0 to log into ftp.lib.pku.edu.cn (or any other ftp servers
containing directories with Chinese names)
2.Try to dive into the directories with Chinese names.

    

Actual Results:  gftp can't enter those directories. 

Expected Results:  gftp should be able to enter those directories freely, just
like gftp 1.0 does.

Additional info:

My locale is zh_CN.GB18030 (Simplified Chinese).

Comment 1 Warren Togami 2004-04-15 04:54:52 UTC
Is this still an issue with FC1 or FC2 development?

Comment 2 Leon Ho 2004-06-10 05:42:27 UTC
Created attachment 101020 [details]
Screenshot

Thanks for your report. I am using FC2 and it works for me. Please confirm
again if that's not the same case. Attached is the screenshot.


Note You need to log in before you can comment on or make changes to this bug.