Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84894 (Arabic-KDE) - Arabic KDE/GNOME Interface
Summary: Arabic KDE/GNOME Interface
Keywords:
Status: CLOSED RAWHIDE
Alias: Arabic-KDE
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
: 84896 (view as bug list)
Depends On:
Blocks: 84896
TreeView+ depends on / blocked
 
Reported: 2003-02-23 06:00 UTC by Ossama Khayat
Modified: 2013-01-10 21:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-18 23:56:56 UTC


Attachments (Terms of Use)
Arabized KDE Menu (deleted)
2003-02-23 06:05 UTC, Ossama Khayat
no flags Details
Showing KWORD as an example (deleted)
2003-02-23 06:10 UTC, Ossama Khayat
no flags Details
RH 8 GNOME screenshot (deleted)
2003-02-23 11:08 UTC, Ossama Khayat
no flags Details

Description Ossama Khayat 2003-02-23 06:00:48 UTC
Description of problem:
Uptill now, all of RedHat Linux releases didn't have the Arabic-i18n for KDE nor
for GNOME. All files needed are included but they are just not compiled like the
others. It would be great if you can:
  1. Add support for KDE/GNOME Arabic Interface
  2. Add Arabic fonts (GPLed) which are available on the net

I will attach screen shots of KDE from RedHat 7.3, which I created from the
KDE-i18n-xxx.src.rpm file available on the sources CD.

The url for the fonts is:
http://www.arabeyes.org/download/3rd/haydar_fonts.tar.bz2
http://www.arabeyes.org/download/3rd/kacst_fonts.tar.bz2

Both of these font sets will have fonts suitable for graphical interfaces as
well as text based ones.

Comment 1 Ossama Khayat 2003-02-23 06:05:29 UTC
Created attachment 90286 [details]
Arabized KDE Menu

Showing Arabized menu.

Comment 2 Ossama Khayat 2003-02-23 06:10:04 UTC
Created attachment 90287 [details]
Showing KWORD as an example

Comment 3 Ossama Khayat 2003-02-23 06:23:02 UTC
*** Bug 84896 has been marked as a duplicate of this bug. ***

Comment 4 Mohamed Eldesoky 2003-02-23 10:17:18 UTC
Also, the arabic fonts issue was solved already, I can't find the bug report number.


Comment 5 Ossama Khayat 2003-02-23 11:00:34 UTC
Well, I re-checked RedHat 8. By specifying your language ar Arabic (Egypt) for
example, and using GNOME, you'll see that the menues are still displayed from
left to right and English. Some names are in Arabic and if you notice in the
screen shot the direction of the window is RTL, though Arabic is broken.
The other bug number is 79394 and it's taking about adding Arabic support to
Anaconda as well as adding Arabic fonts only.
Finally, I tried contacting http://i18n.redhat.com/ via the website, for helping
in translating Redhat components, for the second time yesterday, but still no
answer!

Comment 6 Ossama Khayat 2003-02-23 11:08:42 UTC
Created attachment 90290 [details]
RH 8 GNOME screenshot

Comment 7 Mohamed Eldesoky 2003-02-23 11:15:58 UTC
The same here, i18n at redhat is not responsive at all. 
I am contacting them for more than 2 months. 
Should we file a bug report regarding that ? 

Comment 8 Ossama Khayat 2003-03-03 05:29:02 UTC
Seems like there's still no answer from i18n at RedHat. Some at the mailing list
suggested that we just get the .po files and translate them, then find someone
who has a CVS account to upload them. Should we do this or just file a bugzilla
about i18n?

Comment 9 Bill Nottingham 2003-03-03 21:03:29 UTC
We're working on solving the i18n issue internally. As mentioned, other
translators only have commit access to their languages.

Comment 10 Ngo Than 2003-05-09 09:34:29 UTC
kde-i18n-3.1.1-1 now includes Arabic i18n.


Note You need to log in before you can comment on or make changes to this bug.