Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84877 - Cant'mount using nfs using laptop
Summary: Cant'mount using nfs using laptop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-nfs
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-22 20:55 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-25 04:21:19 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-02-22 20:55:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; WMM)

Description of problem:
I can mount another directory from one DESKtop on another DESKtop, But when i 
try to doe the same thing on a laptop i get errors.

export on desktop -> mount command on laptop -> mount : RPC : time out

export on laptop --> mount command on desktop -> mount : RPC : portmapper 
failure - RPC : Unable to receive.

On both machine the exportfiles are correctly filled. And before giving the 
command i did a service nfs restart, to be sure.

If i reboot the desktop in windows98 and try to mount a directory on the laptop 
using samba, it works fine.

On both machines the same version of redhat is running and all packages are 
installed. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mount -t nfs Desktop:/home/1 /import (command given on laptop)
2.mount : RPC : time out
3.
4. mount -t nfs Laptop:/home/2 /import (command given on Desktop)
5. mount : RPC : portmapper failure - RPC : Unable to receive.

Actual Results:  nfs directory's not mounted

Expected Results:  mounted directory's because all the deamons are running, 
there is an network connection, otherwise i could also not mount a directory in 
windows using samba.

Additional info:

Comment 1 Brent Fox 2003-02-25 04:21:19 UTC
I think you have your firewall security level set too high.  It is blocking the
NFS connection.

Comment 2 Brent Fox 2003-02-25 04:21:43 UTC
Take a look at http://www.justlinux.com/forum/showthread.php?threadid=82798 for
more information.

Comment 3 Need Real Name 2003-02-25 20:08:25 UTC
With setting the eth0 to trusted, 
or the firewall to disabled it works.

Thanx

I don't understand why samba is not also stopped by the firewall ?



Note You need to log in before you can comment on or make changes to this bug.