Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84861 - install error - user named does not exist - phoebe 3
Summary: install error - user named does not exist - phoebe 3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On: 84891
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-22 07:22 UTC by keith adamson
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-21 13:19:39 UTC


Attachments (Terms of Use)

Description keith adamson 2003-02-22 07:22:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Installing bind via "up2date -i caching-nameserver" produces these errors:

warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root

But does add to /etc/passwd:

named:x:25:25:Named:/var/named:/sbin/nologin

And seems to install OK

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run "up2date -i caching-nameserver"
2.get error:
warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root
3.
    

Additional info:

Comment 1 Bill Nottingham 2003-02-24 04:01:15 UTC
Are you using nscd?

Comment 2 keith adamson 2003-02-25 01:26:44 UTC
No.  Could it be that when I ran "up2date -i caching-nameserver" and the "bind"
package was added automatically by up2date ("bind" wasn't installed before hand)
but up2date actually installed the "caching-nameserver" package before the
"bind" package and it's the "caching-nameserver" package complaining because the
"bind" package hasn't added the "named" user id yet?

Comment 3 Bill Nottingham 2003-02-25 01:30:20 UTC
If that happens, that's an up2date bug.

Comment 4 keith adamson 2003-02-25 03:54:58 UTC
Well I tested it and that's the case.  Install caching-nameserver alone:

# up2date -i caching-nameserver
  
Fetching package list for channel: redhat-linux-beta-i386-phoebe-8.0.94...
########################################
  
Fetching Obsoletes list for channel: redhat-linux-beta-i386-phoebe-8.0.94...
########################################
  
Fetching rpm headers...
########################################
  
Testing package set / solving RPM inter-dependencies...
########################################
caching-nameserver-7.2-7.no ########################## Done.
bind-9.2.1-16.i386.rpm:     ########################## Done.
Preparing              ########################################### [100%]
warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root
warning: user named does not exist - using root
warning: group named does not exist - using root
  
Installing...
   1:caching-nameserver     ########################################### [100%]
   2:bind                   ########################################### [100%]
The following packages were added to your selection to satisfy dependencies:
  
Name                                    Version        Release
--------------------------------------------------------------
bind                                    9.2.1          16
  
#

Now install both caching-nameserver and bind at once:

# up2date -i caching-nameserver bind
  
Fetching package list for channel: redhat-linux-beta-i386-phoebe-8.0.94...
########################################
  
Fetching Obsoletes list for channel: redhat-linux-beta-i386-phoebe-8.0.94...
########################################
  
Fetching rpm headers...
########################################
  
Testing package set / solving RPM inter-dependencies...
########################################
bind-9.2.1-16.i386.rpm:     ########################## Done.
caching-nameserver-7.2-7.no ########################## Done.
Preparing              ########################################### [100%]
  
Installing...
   1:bind                   ########################################### [100%]
   2:caching-nameserver     ########################################### [100%]
#

Comment 5 Adrian Likins 2003-02-25 04:05:36 UTC
depends on #84891, but that has been fixed, so this is going to modified

Comment 6 Matt Jamison 2003-05-21 13:19:39 UTC
verified to work with up2date-3.1.23-1

resolving bug.


Note You need to log in before you can comment on or make changes to this bug.