Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84845 - eth10 not initialized on boot
Summary: eth10 not initialized on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: initscripts
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard: Please target Update3
Depends On:
Blocks: 87937
TreeView+ depends on / blocked
 
Reported: 2003-02-21 23:38 UTC by Eric Schwartz
Modified: 2014-03-17 02:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-19 19:13:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:341 normal SHIPPED_LIVE New initscripts packages available 2003-12-19 05:00:00 UTC

Description Eric Schwartz 2003-02-21 23:38:43 UTC
Description of problem:
At boot time, only eth0-9 are initialized.  eth10 is available and exists,
but is not initialized.  When run from the command line after system has
booted up, '/etc/init.d/network restart' finds all 11 interfaces.  This
appears to be indepdendent of which card corresponds to which interface.

Version-Release number of selected component (if applicable):
6.47.1-1

How reproducible:
100%

Steps to Reproduce:
1. Install > 10 network interfaces in a system.  Verify that 
   '/etc/init.d/network start' will in fact start them all.
2. Reboot.
3. Watch startup messages; notice that only eth[0-9] are configured.
4. After boot, restart networking manually; watch eth10 be configured.

Actual results:
eth10 is not configured on boot, but is afterwards.

Expected results:
All interfaces are configured at boot time.

Additional info:
It's not easy being green.

Comment 1 Eric Schwartz 2003-04-03 18:19:50 UTC
It's been a couple of weeks-- has anyone taken a look at this bug yet?

Comment 2 Bill Nottingham 2003-04-03 20:27:54 UTC
Not yet, no.

Comment 3 Larry Troan 2003-07-31 02:41:59 UTC
ISSUE TRACKER 26386 opened as sev 1.
Note that this is at most a sev 2 as indicated in the Bugzilla.

Comment 4 Bill Nottingham 2003-09-04 03:10:08 UTC
Is this at all related to 98209 (I don't have such a machine immediately
available....)

Comment 5 Larry Troan 2003-10-16 21:48:00 UTC
Glen provided two tulip (quad-port 10/100 EN) cards for Bill Nottingham to test
with. Passing cards to Bill. 

Comment 6 Larry Troan 2003-10-16 22:04:54 UTC
HP-IPF SAYS MUSTFIX BUG FOR UPDATE3. They have big hardware with more than 10
NICs and need this fixed. Suggest we add blocker bug 87937 but this was
clarified this week so need ruling from Chris/Tim to add blocker. HP provided
hardware to test which I passed to notting.

Comment 7 Bill Nottingham 2003-11-11 20:16:52 UTC
Works for me with initscripts-6.47.3-1.

Comment 8 Bill Nottingham 2003-11-11 20:17:37 UTC
I'm going to assume that this is related to bug 98209; it's the only
relevant change that could have caused this to start working.

Comment 9 John Flanagan 2003-12-19 19:13:49 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-341.html



Note You need to log in before you can comment on or make changes to this bug.