Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84839 - error compiling netsym in net dir
Summary: error compiling netsym in net dir
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.3
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 22:23 UTC by corey
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 12:24:38 UTC


Attachments (Terms of Use)

Description corey 2003-02-21 22:23:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
make[2]: Entering directory `/usr/src/linux-2.4.18-3/net'
cc  -D__KERNEL__ -I/usr/src/linux-2.4.18-3/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=i686 -malign-functions=4    -DKBUILD_BASENAME=socket  -c -o socket.o socket.c
cc  -D__KERNEL__ -I/usr/src/linux-2.4.18-3/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=i686 -malign-functions=4    -DKBUILD_BASENAME=netsyms  -DEXPORT_SYMTAB -c netsyms.c
In file included from /usr/src/linux-2.4.18-3/include/net/tux.h:38,
                 from netsyms.c:27:
/usr/src/linux-2.4.18-3/include/net/tcp.h: In function `tcp_listen_lock':
/usr/src/linux-2.4.18-3/include/net/tcp.h:1784: Internal error: Segmentation fault.

did 
make oldconfig
make bzImage

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. make oldconfig
2. make bzImage
3.
    

Actual Results:  continued past 'nothing to do' areas and started at net folder again

Additional info:

did not actually modify kernel source

Comment 1 Richard Henderson 2004-10-03 12:24:38 UTC
The kernel has built since then.


Note You need to log in before you can comment on or make changes to this bug.