Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84817 - VNC Restart needs pause between Stop and Start
Summary: VNC Restart needs pause between Stop and Start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 17:07 UTC by Ronald W. Heiby
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-08 14:03:26 UTC


Attachments (Terms of Use)

Description Ronald W. Heiby 2003-02-21 17:07:33 UTC
Description of problem:

When /etc/init.d/vncserver is invoked with "restart" or "condrestart", it runs 
its "stop" procedure and then its "start" procedure. In most init scripts, this 
behavior is fine. However, in the case of vncserver, a directive to shut down 
the vnc server instances might not be instantaneous.

I suggest a "sleep 10" between the "stop" and "start" lines as a quick fix. 
Better might be to explicitly wait for the servers to exit.

How reproducible: Very

Steps to Reproduce:
1. Configure vncserver init script to start a session
2. Connect to that session
3. From another login, invoke /etc/init.d/vncserver restart
4. Observe that although the vnc session goes away, it does not get restarted.
    
Actual results:

Since the VNC server has not yet completely exited, it appears to already exist 
when the "start" is invoked. Naturally, "start" fails to invoke another 
instance. When the "stopping" instance finally goes away, there is no VNC 
server for the user on that system, until either reboot or other invocation 
of "/etc/init.d/vncserver start".

Expected results:

Existing VNC servers go away. New instances of the configured VNC servers are 
started.

Additional info:

This was observed on a fairly fast P4 system. However, I suspect that the more 
things are running within the VNC session(s), the more likely this result will 
be.


Note You need to log in before you can comment on or make changes to this bug.