Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84813 - Anaconda fails to recognize the right ISO image name during HD install
Summary: Anaconda fails to recognize the right ISO image name during HD install
Keywords:
Status: CLOSED DUPLICATE of bug 75077
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 16:30 UTC by Oleg Kozitski (Tokyo)
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:55 UTC


Attachments (Terms of Use)

Description Oleg Kozitski (Tokyo) 2003-02-21 16:30:09 UTC
Description of problem:
Anaconda erroneously tries to use psyche-docs.iso instead of psyche-i386-disc1.iso during HD install from a spare partition. 
The Python module /usr/lib/anaconda/harddrive.py throws "TypeError: an integer is required" as it tries to enumerate RPMS on the wrong installation ISO.

Version-Release number of selected component (if applicable):
Anaconda on RedHat 8.0 Workstation (boot.img) downloaded from FTP server.

How reproducible:
I was trying to do harddisk install of my notebook from the 3 ISO images:
psyche-i386-disc1.iso
psyche-i386-disc2.iso
psyche-i386-disc3.iso 

For this I have created a 3Gb FAT partition and copied there previously downloaded ISOs. For the reasons of conveniency I also copied documentation image file into the the same folder:
psyche-docs.iso 

After booting from FDD with boot.img I was chosen to do a text install because HDD installation.

After the last step of the setup wizard (creating users) the Anaconda crashed with following dump:

[...]
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ? intf.run(id, dispatch, configFileData)
  File "[...]/usr/lib/anaconda/text.py", line 446, in run
  File "[...]/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  File "[...]/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  File "[...]/usr/lib/anaconda/packages.py", line 115, in readPackages
  File "[...]/usr/lib/anaconda/harddrive.py", line 209, in readHeaders
TypeError: an integer is required

Local variables in innermost frame:
sys: <module 'sys' (built-in)>
h: rhl-gsg-en
self: <harddrive.HardDriveInstallMethod instance at 0x83c60b4>
hl: <comps.HeaderListFromFile instance at 0x83dbb1c>


Dispatcher instance, containing members:
method: HardDriveInstallMethod instance, containing members:
  messageWindow: <bound method InstallInterface.messageWindow of
<text.InstallInterface instance at 0x8523d34>>
  discImages: {1: psyche-docs.iso, 2: psyche-i386-disc2.iso, 3:
psyche-i386-disc3.iso}
[...]

If you look at the dump you can see that the value of the local variable h is rhl-gsg-en and the array discImages contains the wrong name of the ISO file.

Conclusion:
Some routine in Anaconda, which enumerates ISO files for HD installation erroneously takes the docs ISO file for the first installation ISO. After deleting the psyche-docs.iso the installation process went through without this error.

Quick solution:
Delete or move out all unnecessary files from the installation folder, especially ISO files.

Correct solution:
Correct the file enumeration routine or make it more sophisticated.

Comment 1 Michael Fulbright 2003-02-21 17:09:45 UTC

*** This bug has been marked as a duplicate of 75077 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.