Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84810 - mouse move slow on boot, fix with system settings
Summary: mouse move slow on boot, fix with system settings
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 16:11 UTC by Bill Glover
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-24 20:49:03 UTC


Attachments (Terms of Use)

Description Bill Glover 2003-02-21 16:11:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When I boot, the mouse moves very slow.

Go to 
system setting => mouse
dialog comes up, leave selection alone
click close
mouse speed now normal.

Same for all users, root and normal. Same with phoebe 0.93 and 0.94

XF86config after boot ....
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

XF86config after opening and closing dialog ....

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

the identifier is changed from "Mouse(0)" to "DevInputMice"

after boot it is changed back to "Mouse(0)"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot and login normal
2.mouse moves slow
3.open    systems settings => mouse
4.mouse select dialog comes up
5.click close with no changes
6.mouse works properly
    

Additional info:

Mouse will move slow if the setting is not poked back to what it should be. The
config setting does not appear to be permanent. It is only session long. Log out
and back in, same slow mouse until you poke the setting type.

Comment 1 Matt Wilson 2003-02-21 16:35:49 UTC
Your XF86Config should have always had both mouse sections.  This is not the
root of the problem.  What kind of mouse?


Comment 2 Bill Glover 2003-02-21 19:21:12 UTC
ooops, you are right, my mistake.

The mouse is an old MS optical. However mouse isn't the problem. I have three
other mice all the same basic PS/2 wheel type. They all do the same thing.
Problem first noticed with phoebe 093 after I did a recent up2date. I waited for
beta3 to check it out.

Several different distros use same test box and mouse they work just fine.

Let me know if I can help test more.

bill

Comment 3 Bill Glover 2003-03-04 17:47:48 UTC
Added comments. 

After installing the B094 again, another consistent behavior is noted. After the
click on OK in Redhat-Mouse-config the mouse cursor zooms off screen lower left.
Moving the mouse will bring the cursor back to visible and it works normally.

bill

Comment 4 Mike A. Harris 2004-09-24 20:49:03 UTC
This seems like the mouse protocol was incorrect, either due to
incorrect autodetection, or incorrect manual selection.  Another
possible issue is our default configuration adding a secondary pointer
for USB devices using /dev/input/mice which may conflict with some
setups, and needs to be manually unconfigured to work around.  In
Fedora Core 2 and later everything uses /dev/input/mice so both
problems should be resolved.

Please try upgrading to Fedora Core 2 if you haven't already, and
if you still experience this or similar problems, please file a new
bug report and we will investigate the problem again on the new
OS release.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.