Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84809 - Kernel 2.4.9-e.12 crash when Amanda-client runs
Summary: Kernel 2.4.9-e.12 crash when Amanda-client runs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 16:08 UTC by Boris Mironov
Modified: 2015-01-08 00:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-23 18:16:45 UTC


Attachments (Terms of Use)

Description Boris Mironov 2003-02-21 16:08:05 UTC
Description of problem:
Kernel 2.4.9-e.12 crash when Amanda-client-2.4.2p2-4 tries to backup big files 
(several Gigs in size).




Version-Release number of selected component (if applicable):

Amanda-Client computer:
RedHat AS2.1
Kernel: 2.4.9-e.12smp
Amanda-client-2.4.2p2-4

Tape server computer:
RedHat 8.0
Kernel: 2.4.18-24.8.0smp
Amanda-server-2.4.2p2-9

How reproducible:
I would not try to reproduce it because it crashed Production Oracle-server


Steps to Reproduce:
1.
2.
3.
    
Actual results:
Server crash

Expected results:
Tape backup

Additional info:
It was comp-root-tar method to backup files

Also Amanda-Client computer is:
-Oracle database server
-Netdump client for netdump-server service that runs on the "Tape backup" 
computer.

Here is "screen shot" from dead Oracle-server

EIP:  0010:[<f8cd3131>] Not tainted
EFLAGS: 00000086
EIP is at freeze_cpu [netconsole] 0x21
eax: f8cd49d5  ebx: f7ffc000  ecx: c02f50a4  edx: 00000003
esi: f7ffc000  edi: f7ffc000  ebp: c0105400  esp: f7ffdf6c
ds: 0018  es: 0018  ss: 0018
Process swapper (pid: 0, stackpage=f7ffd000)
Stack: c01139ef 00000000 c0105400 c02455ba c0105400 f7ffc000 00000003 f7ffc000
       f7ffc000 c0105400 00000000 f7ff0018 f7ff0018 fffffffa c010542e 00000010
       00000246 c0105492 0702080b 00000000 00000000 00000000 00000202 0000000d
Call Trace: [<c01139ef>} smp_call_function_interrupt [kernel] 0x2f
[<c0105400>] default_idle [kernel] 0x0
[<c02455ba>] call_call_function_interrupt [kernel] 0x5
[<c0105400>] default_idle [kernel] 0x0
[<c0105400>] default_idle [kernel] 0x0
[<c010542e>] default_idle [kernel] 0x2e
[<c0105492>] cpu_idle [kernel] 0x32
[<c011c8b8>] printk [kernel] 0xd8
[<c0263c2f>] .rodata.str1.1 [kernel] 0xd2a

Code: eb fd 8d b6 00 00 00 00 8d bc 27 00 00 00 00 55 57 56 53 81
console shuts up ...
 console shuts up ...

Comment 1 Jay Fenlason 2003-02-21 17:09:10 UTC
This is clearly a kernel bug, since nothing any userspace app (including amanda)
does should ever cause a kernel crash.  I'm reassigning it to the kernel folks.

Comment 2 Larry Woodman 2003-02-25 18:35:58 UTC
You really need to try and reproduce this before we can make any progress
debugging this issue.  This basically shows the system is in the netconsole
on one of the CPUs.  Can you attach a serial console and retry running
Amanda???

Larry Woodman


Comment 3 Boris Mironov 2003-02-25 18:41:03 UTC
I use netdump-0.6.6-1 with ethernet connection to 'netdump-server'.
Is it OK? ... Or should I install same thing for serial port?

Thanks,
Boris

Comment 4 Boris Mironov 2003-03-07 21:17:14 UTC
Hi Larry,

Here is another screen shot of the "Screen of death":
CPU:  1
EIP:  0010:[<f8cd3131>] Not tainted
EFLAGS: 00000086
EIP is at freeze_cpu [netconsole] 0x21
eax: f8cd49d5  ebx: f7ffe000  ecx: c02f50a4  edx: 00000001
esi: f7ffe000  edi: f7ffe000  ebp: c0105400  esp: f7ffff6c
ds: 0018  es: 0018  ss: 0018
Process swapper (pid: 0, stackpage=f7fff000)
Stack: c01139ef 00000000 c0105400 c02455ba c0105400 f7ffe000 00000001 f7ffe000
       f7ffe000 c0105400 00000000 f7ff0018 f7ff0018 fffffffa c010542e 00000010
c0384c36 00001356 105492 0102080b 00000000 00000000 00000000 0
(130841611)/       
Call Trace: [<c01139ef>] smp_call_function_interrupt [kernel] 0x2f
[<c0105400>] default_idle [kernel] 0x0
[<c02455ba>] call_call_function_interrupt [kernel] 0x5
[<c0105400>] default_idle [kernel] 0x0
[<c0105400>] default_idle [kernel] 0x0
[<c010542e>] default_idle [kernel] 0x2e
[<c0105492>] cpu_idle [kernel] 0x32
[<c011c5e6>] __call_console_drivers [kernel] 0x46
[<c011c75b>] call_console_drivers [kernel] 0xeb

Code: eb fd 8d b6 00 00 00 00 8d bc 27 00 00 00 00 55 57 56 53 81
console shuts up ...


Best regards,
Boris

Comment 5 Boris Mironov 2003-04-08 18:30:24 UTC
Hello,

Kernel 2.4.9-e14.1smp seems to be free of the bug. Amanda works just fine 
during last several weeks.

Thanks,
Boris

Comment 6 Larry Woodman 2003-06-23 18:16:45 UTC
Problem was fixed long ago.

Larry Woodman



Note You need to log in before you can comment on or make changes to this bug.