Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84794 - Knode fails to open external editor (gvim) with message context
Summary: Knode fails to open external editor (gvim) with message context
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On: 88169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 14:16 UTC by Scott R. Godin
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-07 12:24:36 UTC


Attachments (Terms of Use)

Description Scott R. Godin 2003-02-21 14:16:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
reply to a posted newsgroup message, and choose "Start external editor" from the
Tools menu.

Whether or not the message content is selected, it fails to appear in the
external editor's window and must be manually copy/pasted there.

This works fine with Gedit, but gvim does not seem to open the message content
in the editing window

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open Knode Preferences and choose gvim as your external editor
2.open a newsgroup in knode, and select a message to reply to
3.in the reply window, choose "start external Editor"
4.bang head on keyboard when message content fails to appear in the gvim window
5. change external editor to gedit in knode preferences
6. repeat steps 2-3
7. message content appears in gedit window
8. grind teeth
    

Actual Results:  message content fails to appear in external gvim editor window

Expected Results:  message content appears in external gvim editor window and is
editable. 

Additional info:

I would have filed this against the 'knode' package rather than 'kdebase' but
one does not currently exist in bugzilla's package listing. I've filed a bug
against that as well. *sigh*

Comment 1 Ngo Than 2003-02-22 23:27:44 UTC
It seems that gvim does remove all messages from the file.

Comment 2 Martin Norback 2003-04-07 11:46:45 UTC
I think this is because of the reason described in bug 88169

Comment 3 Karsten Hopp 2003-04-07 12:24:36 UTC
This is the expected behaviour of gvim. Workaround to disable forking is described in bug 
#88169 


Note You need to log in before you can comment on or make changes to this bug.