Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84786 - postinstall scriptlet failed, exit status 127
Summary: postinstall scriptlet failed, exit status 127
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On: 84891
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 12:53 UTC by Michael Schwendt
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-21 13:15:27 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2003-02-21 12:53:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Fresh install of Phoebe 8.0.94. Wanted to add "gstreamer-devel" and "xmms-devel"
with up2date.

Post-install script in package "gstreamer" fails because package
"gstreamer-tools" is not installed first:

error: %post(gstreamer-0.6.0-4) scriptlet failed, exit status 127

$ rpm -q --qf "%{postin}\n" gstreamer
/sbin/ldconfig
env DISPLAY= /usr/bin/gst-register --gst-mask=0 > /dev/null 2> /dev/null

$ rpm -qf /usr/bin/gst-register 
gstreamer-tools-0.6.0-4

So, gstreamer can only be installed after gstreamer-tools. But up2date did
install in wrong order.

Steps to reproduce:

1. rpm -e gstreamer-devel xmms-devel gstreamer gstreamer-tools
2. up2date gstreamer-devel xmms-devel

-snip-

gstreamer-devel-0.6.0-4.i38 ########################## Done.
xmms-devel-1.2.7-19.p.i386. ########################## Done.
gstreamer-0.6.0-4.i386.rpm: ########################## Done.
gstreamer-tools-0.6.0-4.i38 ########################## Done.
Preparing              ###########################################
[100%]

Installing...
   1:gstreamer-devel
########################################### [100%]
   2:xmms-devel
########################################### [100%]
   3:gstreamer
########################################### [100%]
error: %post(gstreamer-0.6.0-4) scriptlet failed, exit status 127
   4:gstreamer-tools
########################################### [100%]
The following packages were added to your selection to satisfy
dependencies:

Name                                    Version        Release
--------------------------------------------------------------
gstreamer                               0.6.0          4
gstreamer-tools                         0.6.0          4

Comment 1 Michael Schwendt 2003-02-21 12:55:01 UTC
Could also be a bug in up2date, because "gstreamer" requires "gstreamer-tools".


Comment 2 Michael Schwendt 2003-02-22 18:26:48 UTC
RPM (rpm -ivh *.rpm) installs the packages in the correct order. up2date does not.

Comment 3 Adrian Likins 2003-02-24 19:25:42 UTC
looks like a result of #84891, which should be fixed on 3.1.21

Comment 4 Matt Jamison 2003-05-21 13:15:27 UTC
verified to work with up2date-3.1.23-1
closing bug.


Note You need to log in before you can comment on or make changes to this bug.