Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84766 - uname -o misrepresents operating system
Summary: uname -o misrepresents operating system
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 03:09 UTC by Michael A. Peters
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-12-10 12:27:20 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2003-02-21 03:09:58 UTC
Description of problem:
uname -o reports GNU/Linux as the operating system.
This is not the operating system. The operating system is Red Hat Linux.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. uname -o
2.
3.
    
Actual results:
GNU/Linux

Expected results:
uname should produce a result that is compatible with what is in /etc/release
(or /etc/redhat-release).

Additional info:

When writing bug report software that reports a bug to the vendor, it is useful
to report the operating system automagically. This could be done with uname -o
from sh-utils if it properly reported the operating system. Instead, it reports
a class of operating system - ones that use the Linux kernel and have some GNU
software installed. Operating systems in this class can vary quite a bit, and
the class of the operating system is useless.

Since Red Hat (and many others) do not have an /etc/release file by default,
using uname -o is a second way for bug reporting software to get operating
system information, if uname -o would report the proper operating system,
opposed to just a class of OS's (which for all practical purposes can be
determined via uname -s)

Comment 1 Tim Waugh 2004-12-10 12:27:20 UTC
-o is not specified by POSIX and so can't be relied upon anyway.


Note You need to log in before you can comment on or make changes to this bug.