Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84752 - redhat-control-network: No admin password prompt, copy fails
Summary: redhat-control-network: No admin password prompt, copy fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 84800 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-21 00:08 UTC by Chris Negus
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-25 15:37:53 UTC


Attachments (Terms of Use)

Description Chris Negus 2003-02-21 00:08:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I launched redhat-control-network (from System Tools --> Network Device
Control), I was not prompted to enter the root password (there were no keys on
the panel either). An error pop-up window appeared, saying:

Error copying
/etc/resolv.conf to /etc/sysconfig/networking/profiler//default/resolv.conf
[Errno 13] Permission denied
/etc/sysconfig/networking/profiler//default/resolv.conf

Other pop-up windows said the same thing for /etc/hosts and /etc/ifcfg-eth0.

The window launches fine from a Terminal window while logged in as root.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Login as regular user
2.Launch redhat-control-network (System Tools --> Network Device Control)
3.Pop-up windows appear, describing copy failures.
    

Actual Results:  After those failures, the Network Device Control window showed
no network interfaces and I was not able to use any of the configuration options.

Expected Results:  Should have prompted for root password and allowed me to
configure network interfaces.

Additional info:

Comment 1 Josiah Royse 2003-02-21 14:45:50 UTC
Happens to me on phoebe-3, redhat-config-network-1.1.97-1

Comment 2 Charles 2003-02-21 15:03:32 UTC
This happens to me too.  I reported a duplicate bug (84800) regarding this.

Comment 3 Harald Hoyer 2003-02-21 15:04:29 UTC
*** Bug 84800 has been marked as a duplicate of this bug. ***

Comment 4 Harald Hoyer 2003-02-25 15:37:53 UTC
more or less fixed


Note You need to log in before you can comment on or make changes to this bug.