Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84748 - doesn't handel cdrom correctly - phoebe 3
Summary: doesn't handel cdrom correctly - phoebe 3
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 23:41 UTC by keith adamson
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-10 12:07:07 UTC


Attachments (Terms of Use)

Description keith adamson 2003-02-20 23:41:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
after starting redhat-config-packages i add packages and click "update" and get
message "disk <n> needed" i insert disk into /dev/cdrom1 -> /dev/scd0 and end up
with "error installing package" dialog.

works ok if i use /dev/cdrom -> /dev/hdd

hdd: ATAPI 48X CD-ROM drive, 128kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: PLEXTOR   Model: CD-R   PX-W1210A  Rev: 1.08
  Type:   CD-ROM                             ANSI SCSI revision: 02

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-packages from menu
2.pick some package
3.install
4.redhat-config-packages asks for disk
5.i insert disk in /dev/cdrom1 -> /dev/scd0
6.gnome automounts disk
7.redhat-config-packages doesn't like ... error diaolg and umounts disk
    

Actual Results:  no packages installed

Expected Results:  read and install packages from /dev/cdrom1 -> /dev/scd0

Additional info:

Comment 1 Jeremy Katz 2003-02-21 21:54:34 UTC
What was the error dialog you received?

Comment 2 keith adamson 2003-02-22 03:25:21 UTC
| Error installing packages
|
| There was an error installing packages.
|
| Exiting.

BTW this happens on another machine also

hdc: Hewlett-Packard CD-Writer Plus 9300, ATAPI CD/DVD-ROM drive
hdd: Pioneer DVD-ROM ATAPIModel DVD-106S 010, ATAPI CD/DVD-ROM drive

hdd: ATAPI 40X DVD-ROM drive, 256kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: HP        Model: CD-Writer+ 9300   Rev: 1.0c
  Type:   CD-ROM                             ANSI SCSI revision: 02


Comment 3 Jeremy Katz 2003-02-24 22:01:16 UTC
Can you try with 1.1.8-1 at
http://people.redhat.com/~katzj/redhat-config-packages/1.1.8/?  If it fails, are
there any messages spewed to the tty you started redhat-config-packages from (or
~/.xsession-errors if you started from the menus and logged in via *dm)?

Comment 4 keith adamson 2003-02-25 02:12:27 UTC
Well the new package now works on "/dev/cdrom1 -> /dev/scd0" but fails on
"/dev/cdrom -> /dev/hdd".  This is the reverse problem now.  Errors from
gnome-terminal on "/dev/cdrom -> /dev/hdd": 

$ 
* Core references package efibootmgr which doesn't exist
* Core references package elilo which doesn't exist
* depcheck: package xemacs needs libRKC.so.1.0 (provided by Canna-libs)
* depcheck: package xemacs needs libcanna.so.1.0 (provided by Canna-libs)
WARNING: Canna-libs had an old state and tried to set it again.  0 to 2
selecting already selected package Canna-libs
* depcheck: package Canna needs libcanna.so.1.0 (provided by Canna-libs)
WARNING: Canna-libs had an old state and tried to set it again.  0 to 2
selecting already selected package Canna-libs
The file /mnt/cdrom/RedHat/RPMS/emacs-21.2-32.i386.rpm cannot be opened. This is
due to a missing file, a bad package, or bad media. Press <return> to try
again.$ ll /dev/cdrom*
lrwxrwxrwx    1 root     root            8 Feb 24 20:38 /dev/cdrom -> /dev/hdd
lrwxrwxrwx    1 root     root            9 Feb 23 22:30 /dev/cdrom1 -> /dev/scd0
$

Here's the same install on "/dev/cdrom1 -> /dev/scd0":

$ redhat-config-packages
* Core references package efibootmgr which doesn't exist
* Core references package elilo which doesn't exist
* depcheck: package xemacs needs libRKC.so.1.0 (provided by Canna-libs)
* depcheck: package xemacs needs libcanna.so.1.0 (provided by Canna-libs)
WARNING: Canna-libs had an old state and tried to set it again.  0 to 2
selecting already selected package Canna-libs
* depcheck: package Canna needs libcanna.so.1.0 (provided by Canna-libs)
WARNING: Canna-libs had an old state and tried to set it again.  0 to 2
selecting already selected package Canna-libs
$



Note You need to log in before you can comment on or make changes to this bug.