Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84745 - redhat-config-kickstart will not open a recently created kickstart file.
Summary: redhat-config-kickstart will not open a recently created kickstart file.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-kickstart
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-20 23:38 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-18 21:05:39 UTC


Attachments (Terms of Use)
patch to fix traceback (deleted)
2003-02-23 23:05 UTC, Jeremy Katz
no flags Details | Diff

Description Larry Troan 2003-02-20 23:38:56 UTC
redhat-config-kickstart will not open a recently created kickstart file
Details:
Server (and Generation): All

Steps to reproduce:

1) Install Red Hat 9.0 Beta 5 (grub/everything)
2) redhat-config-kickstart
3) Create a ks.cfg and save the file in /tmp
4) Click "File" and then "Open File"
5) Select the file you created and saved and click "OK"
6) Notice error messages
   [root@ml350r5 root]# redhat-config-kickstart
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 255, in
on_activate_open
    self.fillData()
  File "/usr/share/redhat-config-kickstart/kickstartGui.py", line 286, in fillData
    self.basic_class.fillData()
  File "/usr/share/redhat-config-kickstart/basic.py", line 303, in fillData
    while iter:
UnboundLocalError: local variable 'iter' referenced before assignment

uname -r output: n/a

Is the issue reproducible? yes.  

Workaround: no
----------
Action by: Bryan.Leopard
Issue Registered

ISSUE TRACKER 16155 opened by HP as sev 2

Comment 1 Bill Nottingham 2003-02-21 00:49:30 UTC
Can you attach the kickstart file?

Comment 2 Jeremy Katz 2003-02-23 23:04:44 UTC
It will happen on any kickstart config that has a langsupport line like
langsupport --default=en_US

Attached patch fixes

Comment 3 Jeremy Katz 2003-02-23 23:05:24 UTC
Created attachment 90301 [details]
patch to fix traceback

Comment 4 Brent Fox 2003-02-24 22:41:05 UTC
Patch applied.  Should be fixed in redhat-config-kickstart-2.3.6-4.  Thanks katzj.

Comment 5 Larry Troan 2003-03-14 02:33:54 UTC
FROM ISSUE TRACKER
Event posted 03-10-2003 12:29pm by Bryan.Leopard with duration of 0.00        
Not fixed in beta 5.  

Comment 6 Brent Fox 2003-03-14 16:35:33 UTC
Beta 5 contained redhat-config-kickstart-2.3.6-2.  The latest tree contains
redhat-config-kickstart-2.3.6-4, which should fix the problem.

Comment 7 Larry Troan 2003-03-28 03:40:14 UTC
FROM ISSUE TRACKER
Event posted 03-25-2003 03:50pm by Bryan.Leopard with duration of 0.00
Still a problem in the GM product.

Comment 8 bcling 2003-06-17 20:15:13 UTC
Note:

There are a bunch of inconsistencies in the GUI generated configuration file:

1. anaconda generated anaconda-ks.cfg includes "=" in --size=XXX
   GUI generated ks.cfg files do not have this
2. The GUI will REQUIRE "=" in --server and --dir settings
3. The GUI creates swap space with a --fstype entry but with no specified type.
   This prevents the kickstart file from being used during an install...

Failure to include the "=" in step 2 will prevent the GUI from opening the file.

Comment 9 Brent Fox 2003-07-10 03:34:01 UTC
bcl: please open a new bug with the problem you are seeing since it does not
appear to be related to the original bug reporter's issue.

Comment 10 Brent Fox 2003-07-10 03:56:03 UTC
I can not duplicate this problem with RHL 9.  If you are still seeing this
behavior, please reopen this bug and attach the kickstart file that
redhat-config-kickstart is crashing on.  Otherwise, I don't have a reproducible
test case.


Note You need to log in before you can comment on or make changes to this bug.