Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84723 - dmidecode prints a lot of garbage and fails on Toshiba Tecra 8100
Summary: dmidecode prints a lot of garbage and fails on Toshiba Tecra 8100
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 21:28 UTC by Alexandre Oliva
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: kernel-utils-2.4-9.1.101.fedora
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-25 17:48:27 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2003-02-20 21:28:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Running dmidecode from kernel-utils-2.4-8.29 on a system running
kernel-2.4.20-2.48 (stock phoebe3) on a Toshiba Tecra 8100 laptop doesn't work
very well.


This causes an error message to be printed when registering the system in RHN. 
It rightfully says it had an error decoding DMI information.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run dmidecode on a Toshiba Tecra 8100

Actual Results:  dmi: read: Success
read: Invalid argument
dmi: read: Invalid argument
[last two lines repeat 20 times or so]
RSD PTR found at 0xF4FD0
checksum failed.
OEM TOSHIB
SMBIOS 2.3 present.
DMI 2.3 present.
42 structures occupying 1251 bytes.
DMI table at 0x07FF0000.
DMI 2.3 present.
[last 4 lines repeat a thounsand times or so] (according to wc -l)]



Expected Results:  Erhm...  I don't have the dmidecode output from earlier
installs, but I'm pretty sure I'd never got this error from up2date --hardware.

Additional info:

Comment 1 Alan Cox 2003-07-28 10:48:45 UTC
phoebe 3 kernel is known broken here, RH9 proper should be working, as should
the beta.(but not alpha3)


Comment 2 Alexandre Oliva 2003-07-28 16:45:15 UTC
Still (or again?) present in Shrike and Severn.  This attachment, from bug
100528 has the dmidecode output on Severn.
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=93171&action=view

Comment 3 Alan Cox 2003-07-28 16:52:47 UTC
If you replace the RH kernel with a generic kenrel does it work ?


Comment 4 Alexandre Oliva 2003-07-31 20:52:43 UTC
Nope.  No difference with the vanilla 2.4.21.tar.bz2, as taken from the Severn
spec file (no rpmbuild -bp, just extracted the tarball without any patches and
used our i686 config files).  On the good side, bug 100920 is gone.  On the bad
side, the pcmcia network card no longer works.

Comment 5 Alexandre Oliva 2003-08-18 20:13:44 UTC
FWIW, using dmidecode 2.2 (as suggested in bug 100528) works.  Maybe we should
update dmidecode in our kernel-utils?

Comment 6 Alexandre Oliva 2003-10-19 19:59:08 UTC
test3 still has the broken dmidecode

Comment 10 Arjan van de Ven 2003-10-19 21:04:20 UTC
It's also of course possible that the bios just has a broken table...


Comment 11 Alexandre Oliva 2003-10-19 21:27:52 UTC
The bug report already mentioned that dmidecode 2.2 fixed the problem.  Of
course it may be that it just knows about brokenness in the BIOS table and works
around it, but it's still an improvement.

Comment 12 Alan Cox 2003-10-20 21:51:48 UTC
The new dmidecode corrects several parsing errors in the old stuff with stranger
tables. The one causing the problem is chronically obsolete



Note You need to log in before you can comment on or make changes to this bug.