Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84720 - redhat-config network is unable to handle two ppp accounts with the same user name
Summary: redhat-config network is unable to handle two ppp accounts with the same user...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 21:13 UTC by Leonid Kanter
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:10:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Leonid Kanter 2003-02-20 21:13:17 UTC
Description of problem: 
 
I have two ppp accounts at two ISPs with the same user name "leon" but different 
passwords. First account was created and tested in redhat-config-network 
successfully. But when I configured second account I found that I'm unable to use 
first account any more. The reason is that there is only one record for user "leon" in 
/etc/ppp/pap-secrets with second password! 
 
Version-Release number of selected component (if applicable): 
 
redhat-config-network-1.1.97-1 
 
How reproducible: 
 
always 
 
Steps to Reproduce: 
1. Start internet-druid and create modem connection with any phone number, 
username "user" and password "passwd1", save changes. 
2. Start internet-druid again and create second connection with any phone number, 
username "user" and password "passwd2". 
3. Open /etc/ppp/pap-secrets 
     
Actual results: 
 
there will be following lines: 
####### redhat-config-network will overwrite this part!!! (begin) ########## 
"user"  *       "passwd2" 
####### redhat-config-network will overwrite this part!!! (end) ############ 
 
i.e. passwd1 disappeared and it's impossible to use first account! 
 
Expected results: 
 
There must be something like: 
 
####### redhat-config-network will overwrite this part!!! (begin) ########## 
"user"  ppp0       "passwd1" 
"user"  ppp1       "passwd2" 
####### redhat-config-network will overwrite this part!!! (end) ############

Comment 2 Harald Hoyer 2003-08-11 14:10:18 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.