Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84683 - grubby failure during kernel upgrade
Summary: grubby failure during kernel upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-02-20 10:41 UTC by Pavel
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-11 03:47:45 UTC


Attachments (Terms of Use)

Description Pavel 2003-02-20 10:41:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030219

Description of problem:
I have a phoebe2 system upgraded to latest rawhide. When I try to upgrade a
kernel to 2.4.20-2.49 I get an error message:
grubby fatal error: unable to find a suitable template 

I tried it with mkinitrd 3.4.35 (comes with phoebe2), 3.4.36 (from up2date) and
3.4.42 (rawhide). 

I didn't modify grub.conf manually (except changing timeout from 10 to 3 seconds).

I had same problems upgarding kernel to 2.4.20-2.48, but somehow I managed to do
it with one of the mkinitrd versions.

My system is Pentium166 MMX if it matters.

My grub.conf file:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda2
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=3
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-2.48)
	root (hd0,0)
	kernel /vmlinuz-2.4.20-2.48 ro root=LABEL=/
	initrd /initrd-2.4.20-2.48.img 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to rawhide kernel
2.
3.
    

Actual Results:  grubby reports an error and does not modify grub.conf

Expected Results:  upgrade kernel

Additional info:

Comment 1 Jeremy Katz 2003-03-20 17:46:52 UTC
Reassigning

Comment 2 Jeremy Katz 2003-04-02 05:58:57 UTC
Does this happen with the final Red Hat Linux 9 release?

Comment 3 Jeremy Katz 2003-06-11 03:47:45 UTC
Closing due to activity.  Please reopen if you have further information to add
to this bug report.


Note You need to log in before you can comment on or make changes to this bug.