Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84663 - duplicate mount point in kickstart file makes it to disk druid screen
Summary: duplicate mount point in kickstart file makes it to disk druid screen
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 04:37 UTC by Alexandre Oliva
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-11 20:27:57 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2003-02-20 04:37:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
If there are two lines in the kickstart file that specify the same mount point, say:

part /boot --fstype ext3 --onpart hde1
part /boot --fstype ext3 --noformat --onpart hdg1

anaconda will display some error messages about the problem, saying it will
reboot, but it does not reboot, and disk druid does display the two partitions
with /boot as the mount point.  I didn't have the courage to proceed to an
install to check what would happen because my hdg1 is no longer suitable for a
/boot filesystem, but it was scary.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a kickstart file with the two entries above, for an interactive
kickstart install.  I had two entries for / too, under the same conditions.
2.run the installer in kickstart mode (interactive)
3.proceed to the disk druid screen

Actual Results:  It says it will reboot, but it doesn't, and then you get two
partitions mounting /boot

Expected Results:  It should have rebooted, and/or cleared one of them, or at
least refused to proceed from disk druid (hmm...  I'm not entirely sure I have
verified that it didn't)

Additional info:

Comment 1 Jeremy Katz 2003-02-20 19:36:23 UTC
Helps to actually exit after showing the error message.... fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.