Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84661 - core dump in regexec
Summary: core dump in regexec
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 04:04 UTC by Ben Fennema
Modified: 2016-11-24 15:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 11:09:26 UTC


Attachments (Terms of Use)
test c file (deleted)
2003-02-20 04:06 UTC, Ben Fennema
no flags Details

Description Ben Fennema 2003-02-20 04:04:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1) Gecko/20021217

Description of problem:
A string with a \n causes a coredump in regexec with some patterns.
The same code executes successfully in RH7.3 (a binary built with 8.0 cores on
8.0, and runs on 7.3. a binary built with 7.3 cores on 8.0 and runs on 7.3)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build testcase.c
2. execute
    

Additional info:

Comment 1 Ben Fennema 2003-02-20 04:06:10 UTC
Created attachment 90204 [details]
test c file

Comment 2 Jakub Jelinek 2003-02-20 11:09:26 UTC
Cannot reproduce this with glibc-2.3.1-50 (in rawhide).
Guess it has been fixed in one of the numerous posix/reg* bugfixes.


Note You need to log in before you can comment on or make changes to this bug.