Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84655 - RH8 installer crashes using LVM
Summary: RH8 installer crashes using LVM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-20 02:43 UTC by Daniel Rubin
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-13 20:40:35 UTC


Attachments (Terms of Use)
one of the exception dumps (deleted)
2003-02-23 18:51 UTC, Daniel Rubin
no flags Details
another exception dump (deleted)
2003-02-23 18:52 UTC, Daniel Rubin
no flags Details

Description Daniel Rubin 2003-02-20 02:43:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
The RH instller crashes in two different circumstances on my system that uses 3 hard drives, both seem to be related to a bug in 
LVM:
 - putting a LVM volume on one disk, and a software raid using two other disks, or 
 - putting a LVM volume on one disk, and second LVM volumne that spans two other disks. 

Here's my configuration: Pentium 4 machine with 3 hard drives; one on one ide bus, and two on another ide bus. 
Here are the details for the two scenarios.

Scenario 1:
When I get to disk druid, I create these partitions on hda: /boot partition (150MB), /swap partition (2GB), and an LVM partition 
"Volume00" (using all remaining space on hda). Then I put three logical partitions on within Volume00. Next, I create a software raid 
partition on hde (whole disk) and a software raid paritition on hdf (whole disk), and tie these two together as /home in a software 
raid. The installer then fails later in the install process. If I try to re-run the installer, it *always* generates an exception when 
disk-druid starts (I can no longer get to the disk druid step in the installer). I get prompted to put in a disk to download the dump 
(see 
below). The only way I can recover from this is to use another program to wipe the disks clean.

Scenario 2:
When I get to disk druid step, I create the same partitions on hda as in Scenario 1 above, including the LVM volume.  I create an 
LVM 
volume on hde that uses the whole disk, and an LVM volume on hdf that uses the whole disk. Then I create a logical volume that 
combines these two lvm volumes. When I get to the part of the part of the install script where it is just about to start installation, the 
installer crashes, and prompts me to put in a disk to capture the dump (see below)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description above.

Actual Results:  Installer crashes after creating an LVM partition on one disk, and a RAID volume that uses two other disks;
Installer also crashes after creating an LVM partition on one disk, and an LVM that uses two other disks.

Expected Results:  Should be able to create the parititions described above. Installer shouldn't crash.

Additional info:

I have two files containing dumps from these exceptions, but I see no way to upload these using this bugzilla webform.

Comment 1 Daniel Rubin 2003-02-23 18:51:46 UTC
Created attachment 90296 [details]
one of the exception dumps

This is one of the exception dumps I describe in the bug report

Comment 2 Daniel Rubin 2003-02-23 18:52:51 UTC
Created attachment 90297 [details]
another exception dump

This is the other exception dump I describe in my bug report

Comment 3 Daniel Rubin 2003-02-23 18:56:07 UTC
I've uploaded the exceptions I describe in the bug report

Comment 4 Michael Fulbright 2003-03-13 20:40:35 UTC
I could not reproduce these issues - vgscan is known to fail if fragments of
data on the disk appear to be LVM. It is not a robust program.

We have changed things to handle vgscan failing more gracefully and this should
address a problem like yours in the future.


Note You need to log in before you can comment on or make changes to this bug.