Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84648 - RPM rebuilding process crashes
Summary: RPM rebuilding process crashes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On: 85346
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 23:42 UTC by Andres Becerra
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 15:57:24 UTC


Attachments (Terms of Use)

Description Andres Becerra 2003-02-19 23:42:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; UNIX) Opera 6.11  [en]

Description of problem:
When rebuilding a large src.rpm file with 

rpmbuild --rebuild <file>

the proces prepares, compiles and installs ok the package in /var/tmp, then the creation of the binary rpm hangs with this message:

getUname: too many uid's

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download http://www.mozart-oz.org/download/mozart-ftp/store/1.2.5-2003-02-12/mozart-1.2.5.20030212-3.src.rpm
2.rpmbuild --rebuild mozart-1.2.5.20030212-3.src.rpm

   

Actual Results:  the binary rpm generation hangs with the the message:
getUname: too many uid's

Expected Results:  It should have created mozart-1.2.5.20030212-3.i386.rpm

Additional info:

Computer: K7 Athlon 
128MB RAM

Comment 1 Jeff Johnson 2003-02-20 15:57:24 UTC
The message
    getUname: too many uid's
comes from execeeding an internal table of 1024
possible usernames.

I believe you have a packaging bug, no package should
need more than 1024 user4 id's.



Comment 2 Denys Duchier 2003-02-22 21:31:45 UTC
Please, reopen this bug report.  The problem that was reported NEVER occurred 
before and DOES NOT occur for everyone.  I and others have successfully 
invoked rpmbuild --rebuild on the src rpm.  Some people, however, have 
reported this getUname issue.  I believe that the problem is with rpmbuild. 
Please, DO try to reproduce the problem.  In all likelyhood, it won't happen 
for you (if it was a problem with the src rpm, it should).  I am the packager for 
this src rpm, I can work with you and make whatever additional information 
you need available.  What I cannot do, is reproduce the problem.  If I could, 
I would have tried to debug rpmbuild by building from sources and running it 
under the debugger. 

Comment 3 Denys Duchier 2003-02-28 13:18:07 UTC
There IS a bug in rpm-build causing the problem:  See #85346. 
 
There seems to ALSO be a packaging problem in that the wrong uid (my name 
instead of root) gets into the src rpm.  My guess is that it is due to effect of 
login vs non-login root shell.  I don't know if that should be considered a bug 
in rpm, but it sure isn't helping.  We never had that problem before. 


Note You need to log in before you can comment on or make changes to this bug.