Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84646 - X hanging system in gingin beta5
Summary: X hanging system in gingin beta5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 23:37 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-27 21:22:40 UTC


Attachments (Terms of Use)

Description Larry Troan 2003-02-19 23:37:55 UTC
Ares -- PE8755MC
X giving black screen and hanging system in anaconda, and in runlevel 5. 
ddcprobe results returned "i8253 count too high! resetting ..."
Also tried vesa driver with same results.
bios X10, 4x1.5mhz, 1gig ram, hyperthreading.

Dump of /proc/pci:
PCI devices found:
  Bus  0, device  29, function  0:
    USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 1).
      IRQ 16.
      I/O at 0x1ce0 [0x1cff].
  Bus  0, device  29, function  1:
    USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 1).
      IRQ 19.
      I/O at 0x1cc0 [0x1cdf].
  Bus  0, device  30, function  0:
    PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 129).
      Master Capable.  No bursts.  Min Gnt=10.
  Bus  0, device  31, function  0:
    ISA bridge: Intel Corp. 82801DB ISA Bridge (LPC) (rev 1).
  Bus  0, device  31, function  1:
    IDE interface: Intel Corp. 82801DB ICH4 IDE (rev 1).
      IRQ 18.
      I/O at 0xfe0 [0xfef].
      Non-prefetchable 32 bit memory at 0x3ffef000 [0x3ffef3ff].
  Bus  1, device   1, function  0:
    SCSI storage controller: LSI Logic / Symbios Logic (formerly NCR) 53c1030
(rev 7).
      IRQ 19.
      Master Capable.  Latency=72.  Min Gnt=17.Max Lat=18.
      I/O at 0x2c00 [0x2cff].
      Non-prefetchable 64 bit memory at 0xfcef0000 [0xfcefffff].
      Non-prefetchable 64 bit memory at 0xfcee0000 [0xfceeffff].
  Bus  1, device   3, function  0:
    VGA compatible controller: ATI Technologies Inc Rage XL (rev 39).
      Master Capable.  Latency=64.  Min Gnt=8.
      Non-prefetchable 32 bit memory at 0xfb000000 [0xfbffffff].
      I/O at 0x2800 [0x28ff].
      Non-prefetchable 32 bit memory at 0xfcedf000 [0xfcedffff].
  Bus  1, device   4, function  0:
    Class ff00: Dell Computer Corporation Embedded Systems Management Device 4
(rev 0).
      IRQ 18.
      Master Capable.  Latency=64.
      Prefetchable 32 bit memory at 0xfdfff000 [0xfdffffff].
      I/O at 0x24f8 [0x24ff].
      I/O at 0x24e8 [0x24ef].
  Bus  1, device   4, function  1:
    Class ff00: Dell Computer Corporation PowerEdge Expandable RAID Controller
3/Di (rev 0).
      IRQ 21.
      Master Capable.  Latency=64.
      Non-prefetchable 32 bit memory at 0xfcede000 [0xfcedefff].
      I/O at 0x2480 [0x24bf].
      Prefetchable 32 bit memory at 0xfdf00000 [0xfdf7ffff].
  Bus  1, device   4, function  2:
    Class ff00: PCI device 1028:000d (Dell Computer Corporation) (rev 0).
      IRQ 22.
      Master Capable.  Latency=64.
      I/O at 0x24f4 [0x24f7].
  Bus  9, device   1, function  0:
    Fibre Channel: QLogic Corp. QLA2312 Fibre Channel Adapter (rev 2).
      IRQ 74.
      Master Capable.  Latency=64.  Min Gnt=64.
      I/O at 0x4c00 [0x4cff].
      Non-prefetchable 64 bit memory at 0xf6eff000 [0xf6efffff].
  Bus  9, device   1, function  1:
    Fibre Channel: QLogic Corp. QLA2312 Fibre Channel Adapter (#2) (rev 2).
      IRQ 75.
      Master Capable.  Latency=64.  Min Gnt=64.
      I/O at 0x4800 [0x48ff].
      Non-prefetchable 64 bit memory at 0xf6efe000 [0xf6efefff].
  Bus 10, device   1, function  0:
    Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit Ethernet
(rev 0).
      IRQ 72.
      Master Capable.  Latency=64.  Min Gnt=64.
      Non-prefetchable 64 bit memory at 0xf6cf0000 [0xf6cfffff].
  Bus 10, device   1, function  1:
    Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit Ethernet
(#2) (rev 0).
      IRQ 73.
      Master Capable.  Latency=64.  Min Gnt=64.
      Non-prefetchable 64 bit memory at 0xf6ce0000 [0xf6ceffff].

----------
Action by: doliver
Issue Registered

ISSUE TRACKER 16031 opened by Dell as Sev 1 (gingin gold blocker)

Comment 1 Larry Troan 2003-02-19 23:40:31 UTC
SOrry, believe correct component is anaconda, not XFree86.

Comment 2 Jeremy Katz 2003-02-20 00:09:13 UTC
If it's hanging during the post-install as well, then it's an X bug.

Comment 3 Mike A. Harris 2003-02-20 01:24:17 UTC
Not sure why this is getting blamed on X, but Intel i8253 is nothing
to do with X.  i8253 is a programmable timer on the motherboard.

This is likely a hardware and/or kernel issue.

Comment 4 Mike A. Harris 2003-02-20 01:24:50 UTC
Just did a quick google...


http://www.uwsg.iu.edu/hypermail/linux/kernel/0212.1/1064.html

Comment 5 Larry Troan 2003-02-23 18:52:53 UTC
From Issue Tracker...
Event posted 02-21-2003 03:51pm by doliver with duration of 0.00
A note that X works in both anaconda and init 5 on previous versions:
7.3, 8.0, AS2.1


Comment 6 Alan Cox 2003-06-05 15:15:52 UTC
XFree86 makes int10 calls. If they mash the timer chip as seems to be i this
case then its an
X problem and thekernel is just noticing it


Comment 7 Mike A. Harris 2004-09-27 21:22:40 UTC
After investigating this, Kevin Martin discovered that the Issue
Tracker report for this has been closed by Dell 18 months ago.
Nothing has been changed in X with respect to this that we're
aware of, so we're assuming this issue was a kernel bug, or some
other transient problem which has worked itself out.

Setting status to "CURRENTRELEASE".  If the problem recurs,
please reopen with new details, and attach new X server log
and config file.

Thanks.

Comment 8 Kevin E. Martin 2004-09-27 21:34:36 UTC
Mike was confused.  The issue tracker issue was closed by the client
on 02-27-2003 because Ares was no longer supported with GinGin, not
because it was fixed or something else has changed.

The issue might still exist, and it should be reopened if the problem
can be reproduced.



Note You need to log in before you can comment on or make changes to this bug.