Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84639 - Switching from working X to VT and back causes Vertrefresh to go out of range
Summary: Switching from working X to VT and back causes Vertrefresh to go out of range
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 22:25 UTC by Chris Kloiber
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-10 16:46:52 UTC


Attachments (Terms of Use)
Customer's XF86Config file (deleted)
2003-02-19 22:26 UTC, Chris Kloiber
no flags Details

Description Chris Kloiber 2003-02-19 22:25:26 UTC
Complaint received via web support ticket# 227394.
---
RH8 up2date as of several days ago.

boot into text mode, run startx, works fine

ctrl-alt-F2 works fine and gives a text console

alt-F7 returns to gui, but screen is shifted to far left, most of display
is black/blank.  Only a couple of inches of gui desktop visible at left side
of screen.  "start here" and "trash" icons visible and selectable.

My or may not be related, but when I switch back to console F1 I see a couple
of error/warnings:

AUDIT: Wed Feb 12 09:42:28 2003: 14279 X: client 4 rejected from local host

and several lines of:

Xlib: extension "RENDER" missing on display ":0:0"

attached is my X config file

Comment 1 Chris Kloiber 2003-02-19 22:26:20 UTC
Created attachment 90199 [details]
Customer's XF86Config file

Comment 2 Chris Kloiber 2003-02-19 22:37:45 UTC
From the description of the display, I thought the monitor is now outside it's
refresh range. The customer says:

Looks like this monitor has built-in protection.  If you try to use synch rates 
outside it's capabilities an on-screen text warning box pops up.

I checked the specs with the manufacturer and set the rates in the config file 
to:

H 30.0-96.0
V 50.0-120.0

At initial boot in text mode the monitor is in Preset#1 31.3x69.8

After startx in gui mode monitor is in Preset#7 60.1x75.1

After ctrl-alt-F2 we're back to Preset#1

But after alt-F7 it's in User#3 55.3x123.2 which is withing the monitor's range 
but not what it was when we entered X the first time.

---

It's interesting that the monitor says it's in 123.2 vert refresh when
the specs say 120 is the limit.  This would seem to confirm your earlier
theory that it's just outside the limits, but counters my earlier observation
where the monitor complained about synch too low or too high.

Comment 3 Mike A. Harris 2004-01-10 16:46:52 UTC
Red Hat Linux 8.0 is no longer supported by Red Hat.  Users who have
experienced the problem described in this bug report should upgrade
to a currently supported OS release, such as Red Hat Enterprise
Linux 3, Red Hat Linux 9, or Fedora Core 1, as this problem may
possibly be fixed in the newer XFree86 release shipped in the newer
OS releases.  The "s3" video driver itself, is more or less shipped
as-is by us, as it handles legacy hardware, and the driver is not
under development anymore, and has no active upstream maintainers.

Problems that happen with the "s3" driver in our current OS releases,
should be reported directly to XFree86.org at http://bugs.xfree86.org
so that the entire team of developers working on XFree86 are aware
of the problem, and someone who has the problematic hardware might
be able to reproduce and fix the issue.

Closing bug as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.