Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84630 - rpm seg faults when installing 3rd party src.rpms
Summary: rpm seg faults when installing 3rd party src.rpms
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
: 84620 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 19:55 UTC by Kendal L. Montgomery
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 15:50:46 UTC


Attachments (Terms of Use)
strace segments describing the problem a bit more. (deleted)
2003-02-19 19:58 UTC, Kendal L. Montgomery
no flags Details

Description Kendal L. Montgomery 2003-02-19 19:55:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
Here's some background on my environment: it is a Red Hat Linux 8.0 (only
version tested) install , set up to authenticate against an openldap server on a
remote machine. Authconfig has been used to set up authentication, but nscd
service is not running (this was accidental and is not the actual problem).

When I try to install almost any 3rd party source rpms (in particular with files
owned / or with groups not known to my ldap server or local /etc/passwd
/etc/group files), I get a segmentation fault.  An example can be found at
http://twtelecom.dl.sourceforge.net/sourceforge/kxmleditor/kxmleditor-0.8.1-0.1.src.rpm.

I've done an rpm -vv --install <package> and normally will get output as such:

D: ============== kxmleditor-0.8.1-0.1.src.rpm
D: Expected size:      1038437 = lead(96)+sigs(100)+pad(4)+data(1038237)
D:   Actual size:      1038405
D: kxmleditor-0.8.1-0.1.src.rpm: MD5 digest: OK (fdee01fecd174d0f4b8a6c7b22a9dbb5)
D:      added source package [0]
D: found 1 source and 0 binary packages
D: Expected size:      1038437 = lead(96)+sigs(100)+pad(4)+data(1038237)
D:   Actual size:      1038405
Segmentation fault

I have also done some stracing as included in the attached file.

It's my assumption that for some reason, without nscd running, doesn't correctly
figure out that the user/group, "lvanek" in this case, does not exist and then
just dies.

I guess my complaint is that it should die a bit more gracefully with an
appropriate error message instead of a seg fault.  This problem really annoyed
me until somehow I figured out that nscd was in fact not running (my fault
totally), by pure luck.

On one other note, this bug *may* be loosely related to bug #84620.

Kendal.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 8.0
2. Set up authentication to LDAP server using authconfig, but don't select the
option to cache information. (or just simply disable nscd, like I accidentally did)
3. Try to install just about any 3rd party source rpm (that was build with the
files owned by a unknown user / and/or group.
    

Actual Results:  Segmentation Fault

Expected Results:  A useful error message, without having to do lots of
stracing, and a graceful exit.

Additional info:

Comment 1 Kendal L. Montgomery 2003-02-19 19:58:30 UTC
Created attachment 90197 [details]
strace segments describing the problem a bit more.

here's the promised attachment with the strace segment that I felt were
relevant.

Comment 2 Jeff Johnson 2003-02-20 15:50:46 UTC
Run nscd, required for statically linked executables like /bin/rpm
when using LDAP. This is a know LDAP problem.

Comment 3 Jeff Johnson 2003-02-20 15:52:14 UTC
*** Bug 84620 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.