Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84620 - RPM crashes with ldap entries in /etc/nsswitch.conf
Summary: RPM crashes with ldap entries in /etc/nsswitch.conf
Keywords:
Status: CLOSED DUPLICATE of bug 84630
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 18:31 UTC by Chad Cunningham
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:53 UTC


Attachments (Terms of Use)

Description Chad Cunningham 2003-02-19 18:31:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:

I have had numerous problems with segmentation faults while attempting to
install RPM's. I haven't seen a pattern with what rpm's cause this, some RPM's
install fine, others cause a segmentation fault. Using strace, I found that the
segfault occurs immediately after rpm reads /etc/nsswitch.conf. As I have made
changes to this to get information out of ldap, I figured it was worth a shot to
try and make it stock. Sure enough, after removing 'ldap' from the entries in
/etc/nsswitch.conf, several rpm's I had been unable to install worked fine. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. attempt to install rpm

Actual Results:  rpm segmentation fault

Expected Results:  installation of rpm

Additional info:

Here is a diff between my nsswitch.conf (that causes the segfaults) and the
stock version:

[root@hooloovoo archives]# diff /etc/nsswitch.conf /etc/nsswitch.conf~
33,35c33,35
< passwd:     files nisplus
< shadow:     files nisplus
< group:      files nisplus
---
> passwd:     files nisplus ldap
> shadow:     files nisplus ldap
> group:      files nisplus ldap
53c53
< protocols:  files nisplus
---
> protocols:  files nisplus ldap
55c55
< services:   files nisplus
---
> services:   files nisplus ldap
57c57
< netgroup:   files nisplus
---
> netgroup:   files nisplus ldap
61c61
< automount:  files nisplus
---
> automount:  files nisplus ldap


-----------

An example RPM that I had this problem with was: 

ftp://apt.unl.edu/apt/8.0/RPMS.kde3-test/lame-libs-3.93.1-0.2.8.0.i386.rpm

Comment 1 Jeff Johnson 2003-02-20 15:52:11 UTC

*** This bug has been marked as a duplicate of 84630 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.