Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84608 - autofs can corrupt /proc/mounts NIS
Summary: autofs can corrupt /proc/mounts NIS
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: autofs
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 15:57 UTC by James McDermott
Modified: 2014-08-25 00:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:52 UTC


Attachments (Terms of Use)

Description James McDermott 2003-02-19 15:57:52 UTC
We have been fairly badly affected by autofs bugs:
#55931 and #65003 in bugzilla.  I have already
attached comments and a suggested workaround to these
bugs; would appreciate feedback and ideally a
new patched version of autofs, 
This is yet another related problem with autofs has 
just come to light which my
workaround is not able to address:

Context: autofs-3.1.7-21 and kernel-2.4.9-e.3
rpms from AS2.1.

automounts are looked up in NIS.  One such
mount is mounted and busy (files under it used
by running processes).  While still mounted,
the NIS maps are changed so that a new mount is
configured for that same mountpoint.

Problem: The next time requests are made for
that mountpoint, autofs will automount the new
mount over the old one.  As Alan Cox suggests in
bug #65003 above, autofs should *never* allow 
multiple mounts on the same point.

----------
Context: autofs-3.1.7-21 and kernel-2.4.9-e.3 rpms from AS2.1. 

----------
Stock ypbind-1.8-1 AS2.1.
There is nothing else installed which could interfere with
this behaviour.

----------
It happened without the patch from bug 65003, but the patch will not
fix the NIS bug, only the two other bugs, since the
patch only affects stopping and starting the autofs
service, whereas the NIS bug is the only bug of the 3
which occurs without doing a stop or a start (or a restart).

That is why my patch is more of a workaround - a proper
fix should probably go in daemon/automount.c in the
autofs source.

Comment 1 Adam Spiers 2003-02-19 17:14:55 UTC
(reported initially by me through Issue Tracker)

Comment 4 Jeff Moyer 2004-03-19 23:02:55 UTC

*** This bug has been marked as a duplicate of 111436 ***

Comment 5 Adam Spiers 2004-06-30 09:19:49 UTC
I do not have access to view bug 111436 so I cannot see the resolution.

Comment 6 Giuseppe Raimondi 2004-06-30 09:46:07 UTC
bug 111436 is an internal bug.
Resolution will probably be RHEL 3 U3 and RHEL 2.1 U5 as mentioned in IT.


Comment 7 Red Hat Bugzilla 2006-02-21 18:51:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.