Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84588 - kbytes vs. bytes mismatch in snmpd.conf
Summary: kbytes vs. bytes mismatch in snmpd.conf
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: net-snmp
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 09:36 UTC by Janne Pikkarainen
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-05 15:24:21 UTC


Attachments (Terms of Use)

Description Janne Pikkarainen 2003-02-19 09:36:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
It seems that the default snmpd.conf has a small but potentially very confusing
typo in it. I think there should read "maxsize_in_kbytes", not
"maxsize_in_bytes" like it currently does.

A quote from snmpd.conf:

---
# file: Check on the size of a file.
#   Display a files size statistics.
#   If it grows to be too large, report an error about it.
#
#    file /path/to/file [maxsize_in_bytes]
---

And my (at first erraneous) settings from snmpd.conf, because it told me to
report the size in bytes:

---
file  /var/log/httpd/access_log 1800000000
---

Now let's see the actual results via snmpget and fileTable:

---
fileMax.1 = INTEGER: 1800000000 kB
---

Woah, that's a little bit bigger than the 1.7-1.8 gigabytes I previously
thought. So, let's check from the UCD-SNMP-MiB which one is right, snmpd.conf or
snmp-get:

---
fileMax OBJECT-TYPE
    SYNTAX      Integer32
    UNITS       "kB"
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
        "Limit of filesize (kB)"
    ::= { fileEntry 4 }
---


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add a file to keep an eye on to snmpd.conf and follow the instructions
precisely, setting the file size in bytes.
2. Check the actual settings with snmp-get.
    

Additional info:

Comment 1 Phil Knirsch 2003-08-05 15:24:21 UTC
I just checked, and neither the example config file nor the manpage contain the
byte reference anymore but only the kilobyte reference.

So it's fixed on the latest versions available via rawhide.

Read ya, Phil

Comment 2 Janne Pikkarainen 2003-08-05 15:34:01 UTC
Ok. Thank you for your information. :-)


Note You need to log in before you can comment on or make changes to this bug.