Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84580 - XFree86 Runs poorly on S3 Savage Twister K 32 meg card
Summary: XFree86 Runs poorly on S3 Savage Twister K 32 meg card
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-19 05:16 UTC by Ardashir Motamed
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 05:39:28 UTC


Attachments (Terms of Use)

Description Ardashir Motamed 2003-02-19 05:16:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
okay, I'm running redhat 8.0, X didn't detect the driver for my graphics card 
and it defaulted to VESA driver.  After that I swithed to the savage driver, 
tux racer runs at 3 fps on a 32 meg card.  Quake 3 is too choppy to play.  Both 
worked fine on my previous laptop which had an ATI Rage 8 meg card.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install Redhat on a computer with a S3 Savage 4 Twister Graphics card
2.
3.
    

Additional info:

Comment 1 Mike Chambers 2003-02-19 05:21:31 UTC
Try filling out the rest of the bug report, with results and expected results. 
Also attach your xfree config file and log file along with dmesg to a text file.
 This will help troubleshoot it better.  Your bug won't get looked at unless you
include these.

Comment 2 Mike A. Harris 2003-02-19 05:39:28 UTC
S3 Savage is 2D only in Linux, zero 3D acceleration - so _all_ OpenGL games
or other software will run slow.  If you need 3D acceleration, you must
use a supported 3D card that there is 3D acceleration support for.

ATI Rage, does not have 3D support, so it would run just as slow.  Unless
your prior card was a Rage 128, which does have 3D support.  Don't confuse
ATI Rage and ATI Rage 128 however.  The former is Mach64, and the latter
is r128.

The "vesa" driver is used for cards which are not officially supported, but
which some user has indicated that they've gotten it to work with the "vesa"
driver after testing.  If we get confirmation that "vesa" works for someone,
then we generally will make the autodetection point to the "vesa" driver
for at least unaccelerated 2D support.

This card is supported now in our latest beta release 'phoebe', again in
2D only.  S3 Savage will never likely have 3D acceleration support in
XFree86 however.

Closing bug as RAWHIDE

Comment 3 Mike A. Harris 2003-02-19 05:45:38 UTC
Oh, also... I forgot to mention..

There is a new S3 savage driver, (the one in rawhide), which I will
possibly include in our next Red Hat Linux 8.0 update also, so this
card might end up being officially supported in 8.0 in the long run
anyway.  Again - 2D only though.



Note You need to log in before you can comment on or make changes to this bug.