Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84562 - basic_string<> template doesn't instantiate char_traits<> for unsigned char
Summary: basic_string<> template doesn't instantiate char_traits<> for unsigned char
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libstdc++
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-18 22:49 UTC by James Antill
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 00:03:04 UTC


Attachments (Terms of Use)
Test code. (deleted)
2003-02-18 22:51 UTC, James Antill
no flags Details

Description James Antill 2003-02-18 22:49:45 UTC
Description of problem:
 If you create a basic_string<unsigned char> the char_traits<> template helper
functions don't exist.

Version-Release number of selected component (if applicable):
 This works with 7.3 (2.96-113) and doesn't work with (3.2-7).

How reproducible:
 Always

Steps to Reproduce:
1. compile attached program as g++ -o basic_string_unsigned basic_string_unsigned.C.
2.
3.
    
Actual results:
 fails to link.

Expected results:
 runs and returns 0.

Additional info:

Comment 1 James Antill 2003-02-18 22:51:06 UTC
Created attachment 90169 [details]
Test code.

Comment 2 Benjamin Kosnik 2003-02-19 00:03:04 UTC
This is not a bug, but a deliberate decision. 

http://gcc.gnu.org/onlinedocs/libstdc++/21_strings/howto.html#5


Note You need to log in before you can comment on or make changes to this bug.