Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84546 - Ability to download only src.rpm from command line
Summary: Ability to download only src.rpm from command line
Keywords:
Status: CLOSED DUPLICATE of bug 53471
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-18 17:52 UTC by Paul Nasrat
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:52 UTC


Attachments (Terms of Use)

Description Paul Nasrat 2003-02-18 17:52:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
For testing, debugging of rpms (eg rawhide) and also for distribution of
problematic 3rd party rpms (eg jpackage.org nosrc.rpms) I would like the ability
to download src rpm only (and nosrc!).  

This would allow me to setup channels with out issues of redistribution using
current (http://current.tigris.org/) for stuff such as jpackage.  I think it'd
be useful for other developers, and people running satellite server who might
want to only grab the upstream src, add a patch or reconfigure an option,
rebuild and distribute the modified package to the satellites.

Currently you can do:

up2date -d package-foo (to download package-foo)
up2date -d --src package-foo (to download both binary and src)

but there is no

up2date -d --src-only package-foo



Version-Release number of selected component (if applicable):
up2date-3.0.7-1 (and grokked the src of up2date-3.1.17-1)

How reproducible:
Didn't try


Additional info:

Comment 1 Adrian Likins 2003-07-28 20:58:16 UTC
should be there in 3.1.46 as --get and --get-source

*** This bug has been marked as a duplicate of 53471 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:52 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.