Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84508 - (SOUND EMU10K1)Soundblaster Live DSP device and microphone not created correctly
Summary: (SOUND EMU10K1)Soundblaster Live DSP device and microphone not created correctly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-18 05:22 UTC by ken conrad
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-11 11:46:44 UTC


Attachments (Terms of Use)

Description ken conrad 2003-02-18 05:22:38 UTC
Description of problem:
On a freshly loaded RH8 system with a soundblaster live card, the install
creates a dsp device with major,minor of 14,3 which won't take input but will
produce output so I think it is actually the microphone. I did get output after
renaming dsp to dsp0 then linking dsp1 to dsp. Also there should be a second dsp
with output because the Soundblaster Live has 4 speakers.

Version-Release number of selected component (if applicable):


How reproducible:
I reloaded twice while testing and verifying and it is repeatable.

Steps to Reproduce:
1. Just load the OS.
2.
3.
    
Actual results:


Expected results:


Additional info:
This is what it looks like after my changes:
lrwxrwxrwx    1 root     root            4 Feb 17 00:53 dsp -> dsp1
crw-------    1 conrake  root      14,   3 Aug 30 19:31 dsp0
crw-------    1 conrake  root      14,  19 Aug 30 19:31 dsp1
crw-------    1 conrake  root      55,   0 Aug 30 19:31 dsp56k

Comment 1 Bill Nottingham 2003-02-18 16:47:07 UTC
Um, no. The devices in /dev are correct. Any misfunction of those devices is a
driver bug.

Comment 2 Alan Cox 2003-06-10 17:48:05 UTC
Does this machine also have a web cam with microphone input - such as the
philiips based ones ?


Comment 3 ken conrad 2003-06-10 22:24:19 UTC
Yes I have a USB Logitech Quickcam Pro 4000.

Comment 4 Alan Cox 2003-06-10 23:07:08 UTC
Ok what is happening here is that on boot Red Hat finds the USB camera with
microphone before the soundblaster live. This makes dsp0 your webcam and dsp1
(which can be opened a ton of times) the emu10k1 hardware

This is a known "oops that wasnt very clever of us" problem with the current Red
Hat.



Comment 5 ken conrad 2003-06-11 00:11:28 UTC
Thank you for the insight. It makes sense now.

Comment 6 Alan Cox 2003-06-11 11:46:44 UTC
The USB devices appearing too early bug has an RFE to fix already so I'll close
this bug now

Thanks for reporting it, sorry you hit it.



Note You need to log in before you can comment on or make changes to this bug.