Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84456 - Badly rendered letters in mozilla with gnome subpixel smoothing
Summary: Badly rendered letters in mozilla with gnome subpixel smoothing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-17 17:28 UTC by Philip Long
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-26 02:11:39 UTC


Attachments (Terms of Use)
PNG of my screen illustrating the problems (deleted)
2003-02-17 17:29 UTC, Philip Long
no flags Details

Description Philip Long 2003-02-17 17:28:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
I'm using mozilla on a SGI 1600SW LCD display and there are two (so far) 
rendering problems with the font rendering.

"m" looks like "rn" becasue there is more whitespace (an extra pixel column?)
between the first column of the m, and the middle one compared to the middle and
the right one. Thus, "computer" reads like "cornputer"

 double quotes look like fat single ticks 

See the attached screenshot

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on subpixel smoothing
2. Launch mozilla
3. Look at text with m or "

    

Actual Results:  Badly rendered font

Expected Results:  Well rendered font

Additional info:

Comment 1 Philip Long 2003-02-17 17:29:00 UTC
Created attachment 90136 [details]
PNG of my screen illustrating the problems

Also shows my mozilla settings

Comment 2 Christopher Blizzard 2003-02-20 21:33:01 UTC
Make sure that you have the most recent mozilla out of rawhide and reset all
your fonts to [System Default].

Comment 3 Philip Long 2003-02-25 21:04:36 UTC
The font rendering looks fine now with mozilla 1.2.1-22.  Keep up the great work
on RH linux!

Comment 4 Christopher Blizzard 2003-02-26 02:11:39 UTC
OK.  Marking as RAWHIDE based on reporter comments.  (Thanks!)


Note You need to log in before you can comment on or make changes to this bug.