Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84453 - ifdown-post not called when pccard ethernet ejected (from ifdown)
Summary: ifdown-post not called when pccard ethernet ejected (from ifdown)
Keywords:
Status: CLOSED DUPLICATE of bug 127283
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hotplug
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-17 16:50 UTC by John Heidemann
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:50 UTC


Attachments (Terms of Use)

Description John Heidemann 2003-02-17 16:50:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
ifdown-post is never called at the end of ifdown
if retcode != 0.
This happens to me consistently when ejecting a pccard ethernet
adaptor.
As a result, jobs registered in /var/run/netreport
never get informed that the network went away.
This breaks third-party apps such as xcron
<http://www.isi.edu/~johnh/SOFTWARE/XCRON/>
that require notification.

(At some previous point ejecting a pccard did trigger netreports.
I'm not sure when: RH 7.3?  7.2?  The code in 7.3 looks the same, but 
maybe the retcode ends up being set differently.)

Presumably this is done because of ungraceful shutdown.  Perhaps
ifdown-post should try and pass the retcode down.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start a process that registers itself in /var/run/netreport
   on a laptop
2. physically eject the card
3. observe that no SIGIO is delivered to the process
    

Actual Results:  a SIGIO is not delivered to the process registered in
/var/run/netreport

Expected Results:  a SIGIO should have been delivred to the process

Additional info:

Comment 1 Bill Nottingham 2003-09-04 01:45:01 UTC
This is because of the switch to hotplug for handling network devices with
PCMCIA/cardbus.

Comment 2 Bill Nottingham 2005-02-04 21:08:16 UTC

*** This bug has been marked as a duplicate of 127283 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.