Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84447 - Open Office does not initialize for new user
Summary: Open Office does not initialize for new user
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: openoffice.org
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-17 13:29 UTC by Philip Long
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 01:15:09 UTC


Attachments (Terms of Use)
$HOME/.openoffice/user/config/.javarc (deleted)
2003-02-17 13:31 UTC, Philip Long
no flags Details

Description Philip Long 2003-02-17 13:29:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
I've got a clean Phoebe install, and when trying to launch /usr/bin/ooffice or
/usr/bin/oowriter for any user (all new home accounts, I'm migrating previous
accounts over) I get:

[plong@localhost plong]$ ooffice
Checking for existing user installation ...   ...   NOT FOUND
Performing first-time installation for user ...

Which sits there doing nothing 

It stops after creating:

/home/plong/.openoffice/user/config/javarc

I haven't installed java yet.  I'll go do that now and try again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. launch open office
2.
3.
    

Actual Results:  Hang on initialization

Expected Results:  Proper user configuration and launch of software

Additional info:

Comment 1 Philip Long 2003-02-17 13:31:18 UTC
Created attachment 90126 [details]
$HOME/.openoffice/user/config/.javarc

The javarc file

Comment 2 Warren Togami 2003-02-18 03:26:39 UTC
What version of OpenOffice?
rpm -q openoffice


Comment 3 Philip Long 2003-02-18 14:02:37 UTC
[plong@localhost plong]$ rpm -q openoffice
openoffice-1.0.1-8

Also, installing java does not help at all.  

Does open office depend on some of 2.5 kernel threading backport that you did? 
I installed phoebe on a Shuttle SN41 (nForce2 board) and had to install a less
patched kernel to get some of the drivers to work.  I'm using the red planet kernel.
 http://ccrma-www.stanford.edu/planetccrma/software/

I ask becuase there There seems to be a thread problem:

 [plong@localhost plong]$ gdb /usr/lib/openoffice/program/setup.bin
GNU gdb Red Hat Linux (5.3post-0.20021129.7rh)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols found)...
(gdb) run -R:/etc/openoffice/autoresponse.conf
Starting program: /usr/lib/openoffice/program/setup.bin
-R:/etc/openoffice/autoresponse.conf
[New Thread 16384 (LWP 2569)]
[New Cannot find thread 32769: invalid thread handle
(gdb) bt
Couldn't get registers: No such process.
(gdb)


Comment 4 Jakub Jelinek 2003-02-18 14:08:58 UTC
Please retry with current rawhide openoffice (1.0.2-2) and glibc (2.3.1-46+).
Our openoffice doesn't use Java at all, so it is expected installing Java
doesn't change a bit.

Comment 5 Philip Long 2003-02-18 16:12:09 UTC
It works now with the rawhide packages.


Comment 6 Mike A. Harris 2003-02-19 01:15:09 UTC
Thanks for your prompt testing and feedback.

Closing as fixed in RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.