Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84442 - bad: Install IP-Alias result in 3x default route to gateway
Summary: bad: Install IP-Alias result in 3x default route to gateway
Keywords:
Status: CLOSED DUPLICATE of bug 88826
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL: http://217.7.11.41
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-17 10:33 UTC by michael mosmann
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:50 UTC


Attachments (Terms of Use)
/etc/sysconfig/network - working (deleted)
2003-02-17 14:38 UTC, michael mosmann
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 - working (deleted)
2003-02-17 14:41 UTC, michael mosmann
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0:1 - working (deleted)
2003-02-17 14:44 UTC, michael mosmann
no flags Details
new error while try to reproduce the error (deleted)
2003-02-17 14:51 UTC, michael mosmann
no flags Details

Description michael mosmann 2003-02-17 10:33:06 UTC
From Bugzilla Helper:


User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MSIE 5.5; Windows NT 4.0) Opera 
7.01  [en]




Description of problem:


After installing eth0:1 config will setup 3x default routes to gateway so 
network will hang




Version-Release number of selected component (if applicable):






How reproducible:


Always




Steps to Reproduce:


Install eth0 with 192.168.2.141/255.255.255.0 gw 192.168.2.2


Everything is ok.




Install eth0:1 with 217.7.11.41/255.255.255.224


After service network restart 






    




Actual Results:  Ziel            Router          Genmask         Flags   MSS 
Fenster irtt Iface


217.7.11.32     *               255.255.255.224 U        40 0          0 eth0


192.168.2.0     *               255.255.255.0   U        40 0          0 eth0


127.0.0.0       *               255.0.0.0       U        40 0          0 lo


default         192.168.2.2        0.0.0.0         UG       40 0          0 eth0


default         192.168.2.2        0.0.0.0         UG       40 0          0 eth0


default         192.168.2.2        0.0.0.0         UG       40 0          0 eth0






Expected Results:  Ziel            Router          Genmask         Flags   MSS 
Fenster irtt Iface


217.7.11.32     *               255.255.255.224 U        40 0          0 eth0


192.168.2.0     *               255.255.255.0   U        40 0          0 eth0


127.0.0.0       *               255.0.0.0       U        40 0          0 lo


default         192.168.2.2        0.0.0.0         UG       40 0          0 eth0








Additional info:




Workaround 1: 


3x route del default


route add -net 0.0.0.0 gw 192.168.2.2


only 2x route del default wont work




Workaround 2:


delete gw in eth0: and remove route 0.0.0.0 0.0.0.0 192.168.2.2 in 
Systemconfig/network before save!


After this 1x default route still exsist(route -e and Systemconfig/network)




You know Workaround 1 can not work after reboot, so you must use Workaround 2.

Comment 1 Harald Hoyer 2003-02-17 14:25:56 UTC
please attach:
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg-eth0
/etc/sysconfig/network-scripts/ifcfg-eth0:1

The first Gateway could come from /etc/sysconfig/network,
the second from ifcfg-eth0 and the third because ifcfg-eth0 is automatically
included by the alias devices.
But this is a flaw in the initscripts then...

Comment 2 michael mosmann 2003-02-17 14:38:57 UTC
Created attachment 90127 [details]
/etc/sysconfig/network - working

working config file after workaround 2

Comment 3 michael mosmann 2003-02-17 14:41:03 UTC
Created attachment 90128 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0 - working

Comment 4 michael mosmann 2003-02-17 14:44:11 UTC
Created attachment 90129 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0:1 - working

Comment 5 michael mosmann 2003-02-17 14:51:09 UTC
Created attachment 90130 [details]
new error while try to reproduce the error

when i try to reproduce the error - and the errornous configfiles - this error
occur

Comment 6 Bill Nottingham 2003-09-04 01:45:44 UTC

*** This bug has been marked as a duplicate of 88826 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:51:50 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.