Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84434 - RFE: Add option to set hostname manually to text installer
Summary: RFE: Add option to set hostname manually to text installer
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-16 23:58 UTC by John Reiser
Modified: 2007-03-27 04:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-25 16:22:25 UTC


Attachments (Terms of Use)

Description John Reiser 2003-02-16 23:58:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
When configuring the network during graphical install, there is an option in the
dialog to set hostname via DHCP or manually.  This option exists and is welcome
because many consumer-grade hardware firewall/router/NAT boxes do only DHCP and
not DNS.  However, the TEXT installer does not have this option to set the
hostname manually.  It should.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Phoebe workstation from CD-ROM in default graphics mode.  On the same
dialog as enable DHCP and AtBoot, note the option to set hostname manually.
2. Install Phoebe workstation from CD-ROM in TEXT mode (boot "linux text"). 
Note that there is no option to set hostname manually.  The "Network Config for
eth0" dialog has only Enable DHCP, AtBoot, and DNS addresses.
3.
    

Actual Results:  TEXT install must set hostname after booting the "fully"
installed system.

Expected Results:  TEXT install should have option to set hostname manually,
just like graphics install.

Additional info:

Comment 1 Michael Fulbright 2003-02-17 14:57:56 UTC
We will consider this request for a future release.

Comment 2 Jeremy Katz 2003-06-16 03:03:35 UTC
This option exists in our current codebase

Comment 3 Mike McLean 2003-06-25 16:22:25 UTC
fix confirmed


Note You need to log in before you can comment on or make changes to this bug.