Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84429 - Cut/paste corrupts long lines
Summary: Cut/paste corrupts long lines
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
: 84035 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-16 20:29 UTC by David Woodhouse
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-09 16:26:39 UTC


Attachments (Terms of Use)

Description David Woodhouse 2003-02-16 20:29:02 UTC
Description of problem:
gnome-terminal inserts extra carriage returns into pasted text if there's
whitespace in the right-hand column when a long line wraps.

Version-Release number of selected component (if applicable):
gnome-terminal-2.1.4-1
vte-0.10.10-1

How reproducible:
100%

Steps to Reproduce:
1. In an xterm with 80 columns, run the command:
echo
"1234567890123456789012345678901234567890123456789012345678901234567890123456789
1234567890123456789012345678901234567890123456789012345678901234567890123456789"

2. Select the output of the above command, paste it back into a terminal.
3. Repeat with an 80-column gnome-terminal.
    
Actual results:
echo 12345678901234567890123456789012345678901234567890123456789012345678901234
12345678901234567890123456789012345678901234567890123456789012345678901234
imladris /home/dwmw2 $
1234567890123456789012345678901234567890123456789012345678901234567890123456789
-bash2:
1234567890123456789012345678901234567890123456789012345678901234567890123456789:
command not found


Expected results:
imladris /home/dwmw2 $ echo
12345678901234567890123456789012345678901234567890123456789012345678901234
1234567890123456789012345678901234567890123456789012345678901234567890123456789
12345678901234567890123456789012345678901234567890123456789012345678901234
1234567890123456789012345678901234567890123456789012345678901234567890123456789
imladris /home/dwmw2 $ 

Additional info:

Comment 1 David Woodhouse 2003-02-16 20:34:11 UTC
Argh. I changed the command used to 'echo "echo...' but forgot to update the
report. Should be obvious enough what I meant anyway.

echo "echo
12345678901234567890123456789012345678901234567890123456789012345678901234
1234567890123456789012345678901234567890123456789012345678901234567890123456789"

(no newlines, only single spaces).


Comment 2 Ray Strode [halfline] 2004-11-09 16:26:39 UTC
This works now, I think.

Comment 3 Ray Strode [halfline] 2004-11-09 17:49:28 UTC
*** Bug 84035 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.