Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84422 - problem with greek fonts in login screen
Summary: problem with greek fonts in login screen
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: fontconfig
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-16 17:52 UTC by Nikos Charonitakis
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-16 23:52:25 UTC


Attachments (Terms of Use)

Description Nikos Charonitakis 2003-02-16 17:52:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
in previous rh version 8.0
no greek font were shown at bottom of login screen
instead we see something like that 
>        >          >
Now in phoebe we can see greek translated messages everywhere
in the login screen but they are tiny and thin and almost
unreadable...

where these fonts properties are defined?

Notes
i ve installed greek fonts(msft)
with old and new method and with gtkrc.mine for gtk1.2
everywhere in the X system they work ok



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install redhat beta phoebe
2.
3.
    

Additional info:

Comment 1 Havoc Pennington 2003-02-16 18:32:00 UTC
The font configuration is in /etc/fonts/fonts.conf

what's going wrong is hard to say since we don't include any greek fonts
to test with.
does "gedit" look ok or are all apps messed up?

Comment 4 Havoc Pennington 2003-02-16 19:31:07 UTC
There's also a gdm theme involved, see /usr/share/gdm/themes/Bluecurve/Bluecurve.xml

perhaps it specifies a problematic font.

Comment 5 Owen Taylor 2003-02-16 21:14:48 UTC
Did you have to explicitely set the font for the GNOME UI in
the font preferences dialog?

Can you get a screenshot of the GDM screen? 

Doing something like:

 Xnest :1 -ac
 DISPLAY=:1 DOING_GDM_DEVELOPMENT=1 gdmgreeter

from the command line should start up the greeter in a window.

Comment 6 Nikos Charonitakis 2003-02-16 23:02:13 UTC
havoc
problem is with Bluecurve
I edit circle's theme circles.xml file and changed Sans to Albany
Result: all is Ok now :)
But the same is not possible with Bluecurve.xml (see the note at the top of file).
So what we need is a way that user can change fonts in Bluecurve.xml file 
Any advice?

Nikos Charonitakis 

Comment 7 Havoc Pennington 2003-02-16 23:08:08 UTC
If changing Sans to Albany works that indicates that your fonts.conf is wrong.
"Sans" and "sans-serif" are required to be a valid font for all languages.

So the correct fix, rather than editing Bluecurve.xml, is to add a valid greek
font to the "Sans" definition in fonts.conf

(I'm not sure if Albany is sans-serif, if it is a serif font you can either 
lie to the font system and get serif fonts everywhere, or you could 
add a sans-serif font to fonts.conf instead)

At least I think this is right, Owen will probably correct me if it isn't.

Comment 8 Owen Taylor 2003-02-16 23:12:31 UTC
Yep, if you don't have any Greek fonts in your Sans/Serif aliases,
fontconfig will pick something fairly random and probably
undesirable.

Note that you shouldn't edit fonts.conf but rather create
an /etc/fonts/local.conf.


Comment 9 Havoc Pennington 2003-02-16 23:34:24 UTC
OK, so it may make sense to add or ask Keith to add some common Greek fonts to 
the default fonts.conf, but otherwise I don't think there's a bug here 
we can address. Moving to fontconfig for decision on upstream or wontfix or 
what.

Comment 10 Owen Taylor 2003-02-16 23:52:25 UTC
Basically, I think the fonts.conf we ship should handle the fonts
we ship, and if you modify your local font configuration, you'll
have to add a local.conf.


Comment 11 Nikos Charonitakis 2003-02-18 14:47:35 UTC
Some additinal info
Another redhat phoebe user reported that in .fonts-cache1 file cant se |el| code
in msft true type
fonts although they include greek characters.
So he couldnt see in mozilla any greek fonts choices when he selected greek lang
He solved  problem modifying el.orth and created fclang.h and recompiling
fontconfig.rpm

--- el.orth~	2002-07-12 21:05:58.000000000 +0000
+++ el.orth	2003-01-26 00:28:05.000000000 +0000
@@ -22,9 +22,6 @@
 # PERFORMANCE OF THIS SOFTWARE.
 #
 # Greek (EL)
-0374-0375
-037a
-037e
 0384-038a
 038c
 038e-03a1


also they made this report:
-----------------------------------------------------------------------------------
  Hello,

  Now that, with the new releases of RedHat, fontconfig is starting to
be used by a lot of people, a problem has been reported with regard to
recognising fonts as being suitable for the greek language. In
particular, it seems that fontconfig fails to accept the majority of
fonts as being adequate for this language.

  It seems that the problem is caused by the inclusion of four
reduntant characters in the greek orthography information:

	  0374	     GREEK NUMERAL SIGN
	  0375	     GREEK LOWER NUMERAL SIGN
	  037A	     GREEK YPOGEGRAMMENI
	  037E	     GREEK QUESTION MARK

  Out of those, the first two are only needed for greek numerals,
sheldom used today; the third is only needed for ancient Greek, and
the fourth is considered to be equivalent with 003B (semicolon), so it
doesn't matter much. So it would be best to eliminate these four
characters from the greek orthography, as shown by the attached
(trivial) patch to el.orth.

  This problem was first reported by Sarantis Paskalis
<sarantis@cnl.di.uoa.gr>. I observed it myself as well, so I took the
liberty to report it here. Please "Reply to All", as I am not
subscribed in this list.

Thanks,
Vasilis

-- Vasilis Vasaitis 
vvas@hal.csd.auth.gr +306976604701 

Comment 12 Nikos Charonitakis 2003-02-18 15:02:16 UTC
i confirm the case for mozilla and .fonts-cache1 
-----------------------------------------------
....|da|de|en|eo|es|et|eu|fi|fj|fo|fr|fur|....
----------------------------------------------
no el code

Comment 13 Nikos Charonitakis 2003-02-18 16:11:20 UTC
finaly
i can see these fat :) Greek fonts of Bluecurve theme using
these rebuilds of phoebe fontconfig.src.rpm

http://cgi.di.uoa.gr/~paskalis/rpms/fontconfig-2.1-3.1.i386.rpm
http://cgi.di.uoa.gr/~paskalis/rpms/fontconfig-devel-2.1-3.1.i386.rpm

Is possible changes to be included in forthcoming release?

Nikos


Comment 14 Sarantis Paskalis 2003-02-19 09:34:11 UTC
It was reported here as bug 83102

The resolution was to let it be fixed upstream.  It is now in fontconfig CVS
(according to http://fontconfig.org/cgi-bin/bugzilla/show_bug.cgi?id=16)

Please consider upgrading the orthography file el.orth to make non-Red Hat
shipped fonts work for Greek.

Some arguments for it:
- The fix is correct.
- It is already in fontconfig CVS.
- If it is in a stable release, it will affect many more users.
- It will only be temporary, until the next version of fontconfig is included in
the distribution.

There is also a .src.rpm with the necessary patches if rebuilding is problematic:
http://cgi.di.uoa.gr/~paskalis/rpms/fontconfig-2.1-3.1.src.rpm

The above src.rpm contains some earlier patches.  If you decide to include it, I
can prepare patches for the latest version of fontconfig and orthography files.

Thanks,

Sarantis



Note You need to log in before you can comment on or make changes to this bug.