Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84406 - Problems with suspend/resume and network
Summary: Problems with suspend/resume and network
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-02-15 22:36 UTC by Kjartan Maraas
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:49 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2003-02-15 22:36:02 UTC
Description of problem:

I have a laptop with an e100 card as eth0 and a orinoco based wlan card as eth1.
I've set them up through redhat-config-network and on boot they work just fine.
However, after suspend resume the pcmcia based WLAN adapter is started as eth0
and the system is confused since it now has the wrong MAC. This leads to modules
not wanting to be unloaded etc and I have to reboot the system to get network up
and running again.

Version-Release number of selected component (if applicable):
This is all the latest stuff from rawhide today.

How reproducible:

Every time.
Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Bill Nottingham 2003-02-18 19:50:57 UTC

*** This bug has been marked as a duplicate of 83996 ***

Comment 2 Peter Bowen 2003-02-19 01:16:29 UTC
you don't have to reboot the system, just do the following:

ifdown eth0; ifdown eth1
rmmod <module list> 

where module list is probably "e100 orinoco_pci orinoco hermes" or something
similar.

Then, if you want to use wireless:
modprobe eth0; ifup eth1
otherwise, if you want to use landline:
ifup eth0; modprobe eth1
otherwise, if you don't want to use either right now:
modprobe eth0; modprobe eth1

This should allow you to avoid the reboot, but it does need to be fixed ;)

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.