Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84386 - rpm --rebuilddb fails with db4 error
Summary: rpm --rebuilddb fails with db4 error
Keywords:
Status: CLOSED DUPLICATE of bug 83281
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-15 12:12 UTC by Daniel Resare
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:49 UTC


Attachments (Terms of Use)

Description Daniel Resare 2003-02-15 12:12:01 UTC
Description of problem:

When I try to rebuild my rpm database with the 'rpm --rebuilddb' command
on my phoebe2 + selected rawhide pieces it always fails with the following
error:

[root@c-6c1a72d5 RPMS]# LANG=C rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy


Version-Release number of selected component (if applicable):
db4-4.0.14-20
rpm-4.2-0.66
glibc-2.3.1-45
kernel-2.4.20-2.48


How reproducible:
have tried 5 times with different db4 and rpm versions from rawhide

Steps to Reproduce:
1. run 'rpm --rebuilddb' as root
2.
3.
    
Actual results:
[root@c-6c1a72d5 RPMS]# LANG=C rpm --rebuilddb
error: db4 error(16) from dbenv->remove: Device or resource busy


Expected results:


Additional info:

The rpm database seems to work with the generated database regardless of the error.

Comment 1 Michael Young 2003-02-15 14:55:03 UTC
Duplicate of Bug 83281

Comment 2 Daniel Resare 2003-02-16 19:09:49 UTC

*** This bug has been marked as a duplicate of 83281 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.