Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84377 - subpixel settings in kcontrol have no effect (but gnome-control-center ones do!)
Summary: subpixel settings in kcontrol have no effect (but gnome-control-center ones do!)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-15 02:30 UTC by Aleksey Nogin
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-08 14:36:05 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 2003-02-15 02:30:23 UTC
After I've upgraded beta4 to Rawhide 03/02, I noticed that some of my fonts
started looking blueish/reddish, both in KDE apps (konsole) and Mozilla (see
also "Rawhide: some fonts appear reddish and blueish in places" thread in
testers-list). Turned out that this was the new subpixel smoothing at work.

There are several issues:
1) Changing (and/or turning off) the subpixel settings in kcontrol
Appearence/Fonts does *not* make any difference (even on the applications that
are started after the changes are made). Note, however, that changing the
settings in gnome-control-center's Font dialog do affect *both* the KDE apps and
Mozilla (but only after restart).

2) Even when both kcontrol and gnome-control-center have subpixel smoothing set
to off, all the applications have it enabled when KDE is first started. I have
to go to gnome-control-center, start the font setting dialog, and then close it
(right away) to get it to go away (but again, only in applications that were
started after that).

3) Similar issues also exist for the dpi settings (except that kcontrol does not
have it at all) - after the gnome-control-center's font setting dialog is
started and closed, all the apps (including KDE ones, such as konsole) start
displaying different size fonts. Here the problem is made worse by the fact that
default dpi is some "random number" (96, I believe) and *not* the X servers' dpi
(BTW, does this deserve a separate bug report?)

Right now I have Rawhide 20030213 and all the above issues are still there.

P.S. Since there appears to be some "weird" KDE-Gnome interaction, I am CC'ing
Gconf and control-center owners.

Comment 1 Aleksey Nogin 2004-04-08 03:29:28 UTC
I am not sure, but this might still be there in Raw Hide :-(

Comment 2 Ngo Than 2004-04-08 14:36:05 UTC
to 1/2)
i cannot reproduce this problem with KDE 3.2.1/fontconfig-2.2.1-8.1 in
rawhide. I see the difference by changing the sub-pixel hinting in
kcontrol/Appearence/Fonts. 

to 3)
it's a bug in Qt, it ignored the DPI settings. But this issue was
fixed in qt-3.3.1-8 in rawhide



Note You need to log in before you can comment on or make changes to this bug.