Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84375 - crashes at end of progress bar when started
Summary: crashes at end of progress bar when started
Keywords:
Status: CLOSED DUPLICATE of bug 74877
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-15 02:09 UTC by gax
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:49 UTC


Attachments (Terms of Use)

Description gax 2003-02-15 02:09:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
redhat-config-packages starts loading the database and crashed towards the end
of the starting process (where the status message shows "Reading system state" )
with :


[root@shark tmp]# redhat-config-packages

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence

[root@shark tmp]# echo $?
0



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.[root@shark tmp]# redhat-config-packages
    

Actual Results:  crashes

Expected Results:  show Add/Remove screen

Additional info:
my rpm DB my be corrupt
was working fine.  hasen't worked since a update of lynx that locked up.
...and that might have happend after a kernel update that locked up as well.

Comment 1 Jeremy Katz 2003-02-17 21:13:59 UTC

*** This bug has been marked as a duplicate of 74877 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.